The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internal 500 Errors - Need free Smart Guy!

Discussion in 'General Discussion' started by tamer1009, May 1, 2010.

  1. tamer1009

    tamer1009 Member

    Joined:
    Apr 1, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i have errors with my server, i get internal 500 errors.

    i checked/deleted htaccess files but thats not the problem.

    i changed the memory limit to 48MB but still errors.

    i need someone who can fix this quick. anyone?

    Regards
     
  2. thewebhostingdi

    thewebhostingdi Well-Known Member

    Joined:
    Jan 10, 2008
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    You will have to check the apache error logs for the exact error message. You can get the logs at /usr/local/apache/logs/error_log.
     
  3. kuldeep_

    kuldeep_ Well-Known Member

    Joined:
    Apr 24, 2010
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Also check Suexec logs at /usr/local/apache/logs/suexec_log
    This will give you extra information of error.
     
  4. dwykofka

    dwykofka Well-Known Member

    Joined:
    Aug 6, 2003
    Messages:
    394
    Likes Received:
    3
    Trophy Points:
    18
    Yup looks like incorrect permissions on a file or folder, error_log should tell you exactly which file/folder.
     
  5. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Which PHP handler?

    If the internal server error is happening when you try to use PHP scripts, you may also need to look at other logs in addition to /usr/local/apache/logs/error_log.

    Check to see which PHP handler you are using. In the WebHost Manager, click Main >> Service Configuration >> Apache Configuration >> PHP and SuExec Configuration. If you are using suPHP, you will need to also check /usr/local/apache/logs/suphp_log. If you are using DSO, then the error_log is the only log you would normally need to check. /usr/local/apache/logs/suexec_log is only used for CGI scripts, so if you are not using CGI as the PHP handler, it would not contain relevant information.

    Also, check the size of the logs, from the shell as root:

    Code:
    # cd /usr/local/apache/logs
    # ls -alh
    If any of the logs in this directory is 2.0 GB or greater in size, then this is the problem. 2.0 GB is a hard limit beyond which Apache cannot write to its log files. To fix the problem, empty the log file that is too large:

    Code:
    # > name_of_too_large_log_file
    where name_of_too_large_log_file is replaced with the actual log filename. ">" will empty the file without deleting it. This is preferable to deleting a log file, because not all applications will create a log file that has been deleted, and it avoids the need to remember the required ownerships and permissions.

    To avoid the problem of too-large Apache log files, enable rotation for the logs in the WebHost Manager at Main >> Service Configuration >> Apache Configuration >> Log Rotation.

    If none of the log files is 2.0 GB or greater, then viewing the error_log and suphp_log in /usr/local/apache/logs should tell you the cause of the error. Using tail -f while viewing a page can help, because you can see the error at the moment it is generated:

    Code:
    # cd /usr/local/apache/logs
    # tail -f error_log
    or

    Code:
    # cd /usr/local/apache/logs
    # tail -f suphp_log
    Use Ctrl+C to end the tail command and return to the shell prompt.
     
Loading...

Share This Page