The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internal error 500 after upgrading to 5.4.20 from 5.3.13

Discussion in 'EasyApache' started by sefelectronics, Oct 1, 2013.

  1. sefelectronics

    Joined:
    Jan 3, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I just update my php version. I recompiled php through easyapache. I ended up with 500 internal error with all my sites. I've been reading around about the error over the forum but none of the solution actually worked for me.

    I actually have PHP 5 Handler empty, i tried to force them with
    /usr/local/cpanel/bin/rebuild_phpconf 5 none suphp 1

    But it says
    PHP5 is not available. Please rebuild apache if you require this configuration.

    I checked apache log but i can't sort out anything.

    I tried to rebuild many times apache either with suPHP enabled or not but still i can't get it work.
    Any help would be much apreciated. Thanks in advance.
     
  2. sefelectronics

    Joined:
    Jan 3, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I managed to solve. It was a mistake in php.ini. I just renamed it and recreated and everything worked
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Thank you for taking the time to let us know that you resolved the issue. Could you let us know the specific entry in your php.ini file that you had to change?

    Thank you.
     
  4. sefelectronics

    Joined:
    Jan 3, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Sure thing,
    Code:
    register_global = On
    For some reason this line was on php.ini after upgrading to 5.4.20. Actually register_global was removed starting from 5.4.x, so I just removed that line and php worked again.
    Documentation: PHP: Using Register Globals - Manual
     
Loading...

Share This Page