Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Internal error: invalid IPv6 address

Discussion in 'E-mail Discussions' started by tmcstom, Sep 6, 2017.

  1. tmcstom

    tmcstom Member

    Joined:
    Dec 31, 2014
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    It appears the latest update to GreyListing's Common Mail Provider list for Comcast IPs have caused Exim to malfunction. The following is shown in /var/log/exim_paniclog

    Code:
    2017-09-06 14:10:36 Internal error: invalid IPv6 address "2001:558:fe16:103:69:252:193::/112" passed to host_aton()
    2017-09-06 14:10:45 Internal error: invalid IPv6 address "2001:558:fe16:103:69:252:193::/112" passed to host_aton()
    2017-09-06 14:10:48 Internal error: invalid IPv6 address "2001:558:fe16:103:69:252:193::/112" passed to host_aton()
    2017-09-06 14:10:51 Internal error: invalid IPv6 address "2001:558:fe16:103:69:252:193::/112" passed to host_aton()
    2017-09-06 14:10:52 Internal error: invalid IPv6 address "2001:558:fe16:103:69:252:193::/112" passed to host_aton()
    2017-09-06 14:10:57 Internal error: invalid IPv6 address "2001:558:fe16:103:69:252:193::/112" passed to host_aton()
    This is causing mail delivery issues. The entries are IPv6 for Comcast.
    Code:
    "2001:558:fe16:103:69:252:193:0/112" # Comcast
    "2001:558:fe16:19:96:114:154:160/123" # Comcast
    "2001:558:fe21:29:69:252:207:0/121" # Comcast
    "2001:558:fe21:30:162:150:58:0/112" # Comcast
    
    To correct this we had to disable Comcast in Common Mail Providers. I have submitted a cPanel bug for this.
     
  2. mike-s

    mike-s Registered

    Joined:
    Aug 7, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Germany
    cPanel Access Level:
    DataCenter Provider
    Update to cPanel 66.0.18 solves this ... if it´s important ;)
     
  3. tmcstom

    tmcstom Member

    Joined:
    Dec 31, 2014
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Looks like cPanel is already aware of this issue, open case CPANEL-14175
     
  4. mike-s

    mike-s Registered

    Joined:
    Aug 7, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Germany
    cPanel Access Level:
    DataCenter Provider
    I have opened a support ticket 120 minutes ago ... it´s assigned to a staff member, still no response :(

    Disabling "comcast" solved this problem at our cPanel 64.x.x boxes. Thanks for this tip!
     
  5. rack::SPEED

    rack::SPEED Member
    PartnerNOC

    Joined:
    Jul 2, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    Germany => NRW => Düsseldorf
    cPanel Access Level:
    DataCenter Provider
    We experienced the same issue since the last upcp run. :/

    To fix this issue use the CLI:

    Code:
    whmapi1 cpgreylist_save_common_mail_providers_config comcast=0 && whmapi1 cpgreylist_untrust_entries_for_common_mail_provider provider=comcast
     
    #5 rack::SPEED, Sep 6, 2017
    Last edited: Sep 6, 2017
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,220
    Likes Received:
    1,376
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Internal case CPANEL-15672 is open to address an issue where Comcast's IPv6 ranges in the common mail providers list are not parsed correctly. I'll monitor this case and update this thread once we publish a resolution. In the meantime, the default common mail providers list we publish has been reverted so the following command will work to solve the issue:

    Code:
    /scripts/setup_greylist_db --update_common_mail_providers
    Thank you.
     
  7. tivilardo

    tivilardo Registered

    Joined:
    Jun 2, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ecuador
    cPanel Access Level:
    Root Administrator
    Today I stopped receiving external emails, so I had to update Cpanel version. Problem solved :)
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,220
    Likes Received:
    1,376
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This is now solved with a publication to the AutoFixer repository. You can run the following command to manually invoke this AutoFixer script if you do not have cPanel updates enabled:

    Code:
    /usr/local/cpanel/scripts/autorepair recoverymgmt
    Thank you.
     
Loading...

Share This Page