GreatPanel

Member
Jun 4, 2003
10
0
151
Hi,

Since I've moved clients from my reseller account to my own server my clients have Internal server error when they use their php scripts. (those scripts was working great on the other server).

I have upgraded PHP to 4.3.4 version and I have fixed permissions (/scripts/chownpublichtmls) but still getting errors.

Do you have any idea?

Thanks
 

casey

Well-Known Member
Jan 17, 2003
2,298
0
191
Did you want to enable phpsuexec or not? If not, you will need to recompile php and make sure that you do not select phpsuexec. If you did, you need to change permissions on their php scripts so that they will run as cgi scripts.
 

GreatPanel

Member
Jun 4, 2003
10
0
151
Originally posted by casey
Did you want to enable phpsuexec or not? If not, you will need to recompile php and make sure that you do not select phpsuexec. If you did, you need to change permissions on their php scripts so that they will run as cgi scripts.

When I upgraded to v4.3.4 i have enable phpsuexec and since this upgrade I got these problems.

What should i do? recompile php and not select phpsuexec or change permissions? How can i do that?

Thanks for your help
 

casey

Well-Known Member
Jan 17, 2003
2,298
0
191
Well, if you want phpsuexec, try running "Fix insecure permissions" in WHM. If you don't want it, then use "Upgrade Apache" from WHM.
 

GreatPanel

Member
Jun 4, 2003
10
0
151
It works now!!!:)

Here's what i do

1) Recompile php, thru whm, unselect phpsuexec
2) Restart apache
3) Recompile php v4.3.4 and select phpsuexec

I don't know why but I know that it fixed the issues. All scripts seems working just great now! :)

Thanks for your time!