Internal Server Error - End of script output before headers

steflan

Registered
Jan 20, 2020
4
0
1
Sydney
cPanel Access Level
Root Administrator
Hi!

We have recently been having issues with our webserver, at least 4-5 times a day users receive an internal server error, as shown in the attached image.

Once we refresh the page the site starts working like normal again, this seems to occur only the first time you access it.

Every time this error occurs, I found the following logs in the apache error log

[cgi:error] [pid 12702] End of script output before headers: ea-php56, referer: [site name]

Has anybody come across this before? Any idea how to fix this?
 

Attachments

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Hello,

Is there anything further directly before or after that error in the logs? There are a ton of reasons you could receive that error. See the following threads for examples;

 

steflan

Registered
Jan 20, 2020
4
0
1
Sydney
cPanel Access Level
Root Administrator
I also noticed this other error in the logs before the end of script error:

AH02811: script not found or unable to stat: /var/www/html/setup.cgi

And this was right after:

[Thu Jan 23 12:17:22.984316 2020] [mpm_prefork:notice] [pid 12155] AH00169: caught SIGTERM, shutting down
[Thu Jan 23 12:17:23.413931 2020] [:notice] [pid 5926] ModSecurity for Apache/2.9.3 (http://www.modsecurity.org/) configured.
[Thu Jan 23 12:17:23.414017 2020] [:notice] [pid 5926] ModSecurity: APR compiled version="1.7.0"; loaded version="1.7.0"
[Thu Jan 23 12:17:23.414027 2020] [:notice] [pid 5926] ModSecurity: PCRE compiled version="8.32 "; loaded version="8.32 2012-11-30"
[Thu Jan 23 12:17:23.414032 2020] [:notice] [pid 5926] ModSecurity: LUA compiled version="Lua 5.1"
[Thu Jan 23 12:17:23.414036 2020] [:notice] [pid 5926] ModSecurity: LIBXML compiled version="2.9.7"
[Thu Jan 23 12:17:23.414041 2020] [:notice] [pid 5926] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
[Thu Jan 23 12:17:23.449740 2020] [:notice] [pid 5929] mod_ruid2/0.9.8 enabled
[Thu Jan 23 12:17:23.453578 2020] [mpm_prefork:notice] [pid 5929] AH00163: Apache/2.4.41 (cPanel) OpenSSL/1.0.2t mod_bwlimited/1.4 configured -- resuming normal operations
[Thu Jan 23 12:17:23.453631 2020] [core:notice] [pid 5929] AH00094: Command line: '/usr/sbin/httpd'
 
Last edited:

steflan

Registered
Jan 20, 2020
4
0
1
Sydney
cPanel Access Level
Root Administrator
I also noticed these other errors in another server having the same issue:

[Wed Jan 22 14:56:47.320361 2020] [cgi:warn] [pid 6481] [client 101.0.71.70:45672] AH01220: Timeout waiting for output from CGI script /usr/local/cpanel/cgi-sys/ea-php56
[Wed Jan 22 14:56:47.320493 2020] [cgi:error] [pid 6481] [client 101.0.71.70:45672] Script timed out before returning headers: ea-php56
[Wed Jan 22 14:59:56.905695 2020] [cgi:warn] [pid 30826] [client 101.0.71.70:56270] AH01220: Timeout waiting for output from CGI script /usr/local/cpanel/cgi-sys/ea-php56
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Hi @steflan
Unfortunately in most cases that error you're getting is a symptom of another problem, the output you're providing though doesn't give me an idea of what that is.
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

steflan

Registered
Jan 20, 2020
4
0
1
Sydney
cPanel Access Level
Root Administrator
It says to go to this link although it just loads forever?

Should I click on "Request support from cPanel, L.L.C. instead of Deluxe Small Business Sales"?
 
Last edited by a moderator: