The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internal Server Error

Discussion in 'General Discussion' started by shibucvarughese, Jul 15, 2005.

  1. shibucvarughese

    shibucvarughese Registered

    Joined:
    Jan 26, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello... getting the following error while accessing
    my-domain-name.com/cpanel or my-domain-name.com/whmor
    my-domain-name.com/webmial
    But my-domain-name.com:2095 etc works fine...
    --------------------------
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    -------------------
    The log has the following message
    Permission denied: exec of /usr/local/cpanel/cgi-sys/whmredirect.cgi failed
    Premature end of script headers: /usr/local/cpanel/cgi-sys/whmredirect.cgi

    any idea how to resolve the issue..i have checked the permission of /usr/local/cpanel/cgi-sys/

    Thanks,
     
  2. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    did you find the solution to this problem?
     
  3. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Try to reboot cpanel:

    /etc/rc.d/init.d/cpanel restart
     
  4. Bakadesu

    Bakadesu Member

    Joined:
    Feb 11, 2005
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    I have same problem, restarting cpanel didn't work
     
  5. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    From which URL you are trying to connect to your whm/cpanel/webmail.....check entries in your httpd.conf ..they should look like >>

    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi


    also check permission on scripts under cgi-sys folder..correct ones are 755
     
    #5 nickb, Sep 3, 2005
    Last edited: Sep 3, 2005
  6. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    If the entries in the hhtpd.conf and correct as sugested by nickb, you can try disabling the SuExec module from the WHM and then have a try.
     
  7. Planet_Master

    Planet_Master Well-Known Member

    Joined:
    Apr 18, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Yorker
    What was the last action you performed on the server?
     
  8. asish

    asish Active Member

    Joined:
    Dec 4, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    I got fixed

    Hello,

    Go to /usr/bin
    Check out for the permissions out there

    chmod -R 775 *
    This will fix the issue
    For me everytrhing got fixed.
     
    #8 asish, Oct 4, 2005
    Last edited: Oct 4, 2005
Loading...

Share This Page