The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internal Server Error

Discussion in 'General Discussion' started by jthomas, Sep 8, 2007.

  1. jthomas

    jthomas Active Member

    Joined:
    Jul 31, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I was playing around with my server this morning and now I am having a problem with my sites. Whenever I go to a site on my server at www.mysite.com in internet explorer it produces an internal server error. However if you visit it without the www the site works fine. All of my subdomains are operating as normal. When you go to www.mysite.com from within firefox, it allows you do download the full php source(VERY BAD). And in firefox the site pulls up without the www just fine. I did not change anything in the DNS zone and double checked the settings. But it is every site on my server that is running into these problems. What in the world could be causing it?
     
  2. jthomas

    jthomas Active Member

    Joined:
    Jul 31, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    OK.. Quick update .. if I go to

    www.mydomain.com it give the internal server error in Internet Explorer and allows the downloading of the index.php file in firefox.

    but if I go to www.mydomain.com/index.php directly it works fine in both browsers.

    I am now officially confused.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Never mentioned what you were playing with.

    Might be helpful for assistance.

    Are you up to date on cPanel? There were some issues in a recent update that have come and gone for some. http://changelog.cpanel.net/

    Sounds like you might need to try an apache upgrade to sort out your php probs. Not sure though, not much to go on.
     
Loading...

Share This Page