The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

InternalDeath!! WHAT???

Discussion in 'General Discussion' started by OCX, Jun 3, 2006.

  1. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
    what does this mean?..should see the puzzled look on my face right now..lol :eek:

    Waiting for whostmgrd to shutdown......Done
    (internal death) Sat Jun 3 21:01:55 2006 [32719] error: List::Util object version 1.14 does not match bootstrap parameter 1.18 at /usr/lib/perl5/5.8.7/i686-linux/XSLoader.pm line 92.
    at /usr/lib/perl5/5.8.7/i686-linux/XSLoader.pm line 92
    XSLoader::load('List::Util', 1.18) called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 25
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 27
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 19
    require List/Util.pm called at /usr/lib/perl5/5.8.7/i686-linux/Scalar/Util.pm line 12
    require Scalar/Util.pm called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 277
    eval {...} called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 276
    require DBI.pm called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBD/mysql.pm line 7
    DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 62
    main::BEGIN() called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    (internal death) Sat Jun 3 21:01:55 2006 [32719] error: List::Util object version 1.14 does not match bootstrap parameter 1.18 at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 30.
    at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 30
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 19
    require List/Util.pm called at /usr/lib/perl5/5.8.7/i686-linux/Scalar/Util.pm line 12
    require Scalar/Util.pm called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 277
    eval {...} called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 276
    require DBI.pm called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBD/mysql.pm line 7
    DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 62
    main::BEGIN() called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/List/Util.pm line 0
    (internal death) Sat Jun 3 21:01:55 2006 [32719] error: Undefined subroutine &Scalar::Util::weaken called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 279.
    at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 279
    eval {...} called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBI.pm line 276
    require DBI.pm called at /usr/lib/perl5/site_perl/5.8.7/i686-linux/DBD/mysql.pm line 7
    DBD::mysql::BEGIN() called at /usr/lib/perl5/5.8.7/i686-linux/Scalar/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/Scalar/Util.pm line 0
    require DBD/mysql.pm called at /usr/local/cpanel/cpanellogd line 62
    main::BEGIN() called at /usr/lib/perl5/5.8.7/i686-linux/Scalar/Util.pm line 0
    eval {...} called at /usr/lib/perl5/5.8.7/i686-linux/Scalar/Util.pm line 0
    [a fatal error or timeout occurred while processing this directive][a fatal error or timeout occurred while processing this directive][a fatal error or timeout occurred while processing this directive]==> cPanel Log Daemon version 22.2
    ==> Shared RRDTOOL support enabled
    ==> Starting cpbandwd (bandwidth monitoring for IMAP/POP)
    Can't locate Class/Std.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.7/Unix/PID.pm line 8.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.7/Unix/PID.pm line 8.
    Compilation failed in require at /usr/local/cpanel/bin/cpbandwd line 15.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cpbandwd line 15.
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    try this:
    /scripts/perlinstaller --force List::Util
    Or you can install any Perl module through the WHM. If that doesn't solve the problem, do this:

    wget http://layer1.cpanel.net/perl584installer.tar.gz
    tar xvzf perl584installer.tar.gz
    cd perl584installer
    ./install
    /usr/local/cpanel/bin/checkperlmodules
     
  3. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16

    now i just get this after running /scripts/perlinstaller --force .....

    ==> Starting cpbandwd (bandwidth monitoring for IMAP/POP)
    Can't locate Class/Std.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.7/Unix/PID.pm line 8.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.7/Unix/PID.pm line 8.
    Compilation failed in require at /usr/local/cpanel/bin/cpbandwd line 15.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cpbandwd line 15.
     
  4. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
    this is during /scripts/upcp --force

    thats where that error pops up on me


    OCX
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    I am sorry, I gave you a dead link to Perl binary package. Please, follow these steps (in that order):

    /scripts/perlinstaller --force List::Util
    Or you can install any Perl module through the WHM. If that doesn't solve the problem, do this:

    wget http://layer1.cpanel.net/perl587installer.tar.gz
    tar xvzf perl587installer.tar.gz
    cd perl587*
    ./install
    /usr/local/cpanel/bin/checkperlmodules
     
  6. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
    thank you KINDLY SIR!!!

    i should of know better to look for the perl mod and install em

    gosh..thats what i get for staying up late :cool:
     
  7. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    I've did all this and it did not helped me.
    I tried to reinstall perl and Util module and on upcp -force I still get:
    ==> Starting cpbandwd (bandwidth monitoring for IMAP/POP)
    Can't locate Class/Std.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.7/Unix/PID.pm line 8.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.7/Unix/PID.pm line 8.
    Compilation failed in require at /usr/local/cpanel/bin/cpbandwd line 15.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cpbandwd line 15.

    Any advice?
     
  8. yaax

    yaax Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Never mind, I finallly found solution.
    I was need to update perl to 5.8.8 and then to reinstall modules Class:Std and Class:Std:Utils and also Ipc:Open3
     

Share This Page