The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet Explorer doesn't show any login box.

Discussion in 'General Discussion' started by farago, Nov 10, 2004.

  1. farago

    farago Registered

    Joined:
    Feb 17, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    What we need to provide our clients.

    FTP access for our clients who (unfortunately) use Internet Explorer as their only FTP client:​

    Behavior we want:

    When ftp.farago.com is typed into a URL in explorer it should bring up a login window. ​

    Behavior we are experiencing:
    see:
    http://www.farago.com/pure/Pure-headache.jpg

    ------------------------------------------------------

    New to cPanel and I am struggeling with this. :eek: There are scripts in multiple places and I don't understand which one is actually controling pure ftpd.

    /scripts/restartsrv_pureftpd
    /etc/sysconfig/pure-ftpd
    /usr/sbin/pure-config.pl
    /etc/pure-ftpd.conf


    found this note on the subject but have been unsuccessfull implimenting it.

    -> Internet Explorer doesn't show any login box.

    IE does a very strange trick to detect whether an FTP server does accept anonymous connections or not. Basically, it connects to the server and logs in as 'anonymous'. But if you say 'no' at this point, it drops the connections with an error. You have to say 'ok, anonymous users are allowed' and then, when a dummy password ('IE@') is sent, you say 'ah ehm... finally... no... anonymous users aren't allowed' . Silly. To play that game, you must run pure-ftpd with the -E (non-anonymous server) and -b (compatibility with broken clients) flags. Then, the magic popup will show up. But please note that IE (and browsers at large) are usually bad FTP clients.

    -> Internet Explorer doesn't want to log in. (Matthew Enger)

    Check that the max number of connections (either per user or per IP) is at least 2. IE needs two connections to connect to an FTP server.​

    Any thoughts and guidance greatly appreciated.

    Thanks!

    Peter :)
     
  2. AX-Hosting

    AX-Hosting Registered

    Joined:
    Mar 24, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK, England
    cPanel Full URL - Is this right?

    I do not remember the full login URL for cPanel, I did have it and I cannot remember it as I made a Login script, but now I need it to design something.

    Thanks.

    (I Thought it was: domain.com:2082/login/user@domain.com+pass)
     
    #2 AX-Hosting, Mar 24, 2005
    Last edited: Mar 24, 2005
  3. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    to log into internet explorer via FTP

    your clients must go to tools in ie
    click internet options
    click the advaced tab
    put a check mark in enable folder veiw for FTP sites
     
  4. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    You could also try disabling anonymous FTP to prevent IE automatically logging in as 'anonymous', thus possibly forcing a login box immediately upon going to ftp://yourdomain
     
  5. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    And if these clients will only or can only use IE as their FTP client there is the chance that they are not the sharpest tools in the box, in which case specifying the FTP address for use in IE as ftp://yourdomain instead of ftp://ftp.yourdomain might make things a slight bit easier for them.
     
Loading...

Share This Page