Invalid Emails Breaking Webmail & Outlook

Varial

Member
Oct 17, 2008
23
5
53
Saskatoon, Saskatchewan, Canada
Over the weekend a handful of our clients have received emails which appear to be invalid/corrupt that break Webmail and cause Outlook to throw errors. This is occurring across several servers and the problem is caused by a single email they receive.

When logged into Horde, you'll see a bunch of Invalid Address emails (see screenshot). If you switch to Roundcube, you'll just see a single invalid email with no subject. Deleting that single email will fix the issue and Webmail will then function properly again.

In Outlook, it will give the following error when an account has received one of these invalid emails:

Receiving' reported error (0x800CCC90) : 'Your incoming (POP3) e-mail server has reported an internal error. If you continue to receive this message, contact your server administrator or Internet service provider (ISP). The server responded: -ERR Message 4 expunged.'

Again, tracking down and deleting the offending email will resolve the problem.

Is anyone else experiencing this and is there anyway for Exim to reject these invalid emails? Might this be some new form of email attack?
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
I now suspect this may be related to Imunify360 quarantining emails in the accounts.
Hello,

Feel free to update this thread with the outcome once you've verified that's the case.

Thank you.
 

Varial

Member
Oct 17, 2008
23
5
53
Saskatoon, Saskatchewan, Canada
The latest update to Imunify360 (2.4-20) forced a changed to the behaviour of quarantined files and they now chmod 000 them in place, which is what is causing this issue. I will be reporting this to CloudLinux.
 
  • Like
Reactions: cPanelMichael