Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED IonCube 10.2.2-1.el7.cloudlinux breaks WHMCS 7.52

Discussion in 'EasyApache' started by Trane Francks, Jul 26, 2018.

  1. Trane Francks

    Trane Francks Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    88
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Machida, Tokyo, Japan
    cPanel Access Level:
    Root Administrator
    Hi, gang.

    In the last EasyApache update with CloudLinux installed on our CloudLinux 7.5 (CentOS 7 base), IonCube went from Experimental to mainstream. Unfortunately, the updated IonCube 10.2.2-1.el7.cloudlinux version broke our WHMCS 7.52 installation, which now shows the following error:

    "Oops!
    Something went wrong and we couldn't process your request.
    Please go back to the previous page and try again."

    It was fine with the previous "Experimental" IonCube 10 version prior to our update of EasyApache. The error is present with all release PHP 7.x versions.
     
    #1 Trane Francks, Jul 26, 2018
    Last edited: Jul 26, 2018
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,472
    Likes Received:
    421
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I 've confirmed this on my end as well.

    This is more of a post for the CloudLinux or WHMCS forums though, isn't it?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Trane Francks

    Trane Francks Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    88
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Machida, Tokyo, Japan
    cPanel Access Level:
    Root Administrator
    Nah. It isn't actually a bug at all. Apparently, this particular version of IonCube has increased memory requirements. We were able to get WHMCS working again by increasing working memory under PHP 7.2.
     
    cPanelLauren and Infopro like this.
  4. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,137
    Likes Received:
    222
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Trane Francks


    Thank you for letting us know what you found the resolution to the issue to be! I'm sure this is going to help someone else!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Trane Francks likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice