cosmos64

Registered
Jan 7, 2020
1
0
1
Karlskoga
cPanel Access Level
Root Administrator
Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance. when i try to install whmcs and i have change some in cpanel for ioncube loader but that still not working for me.

//cosmos
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hello,

Are you aware if you have IonCube PHP loader installed for the version of PHP you're running on the site? You can check this in the EasyApache 4 UI or by running something like the following:

Code:
[[email protected] Whostmgr]# rpm -qa |grep -i ioncube
ea-php70-php-ioncube10-10.3.9-1.1.7.cpanel.x86_64
cpanel-php-ioncube-10.3.9-1.cp1186.x86_64
ea-php73-php-ioncube10-10.3.9-1.1.8.cpanel.x86_64
ea-php72-php-ioncube10-10.3.9-1.1.8.cpanel.x86_64
ea-php71-php-ioncube10-10.3.9-1.1.7.cpanel.x86_64
Note that I have it installed for versions 7.0 - 7.3 of PHP on my test server.
 

mcgwier

Registered
Feb 5, 2020
2
0
1
Austin, Texas
cPanel Access Level
Root Administrator
Same issue here.

@cPanelLauren My results show ionCube is installed for 7.2 and 7.3 but still getting same error as @cosmos64 .
Code:
ea-php70-php-ioncube6-6.1.0-2.2.46.cpanel.x86_64
cpanel-php72-ioncube-10.2.2-1.cp1176.x86_64
ea-php72-php-ioncube10-10.3.9-1.1.8.cpanel.x86_64
ea-php71-php-ioncube10-10.3.9-1.1.7.cpanel.x86_64
ea-php56-php-ioncube6-6.1.0-2.2.49.cpanel.x86_64
ea-php55-php-ioncube6-6.1.0-2.2.41.cpanel.x86_64
ea-php73-php-ioncube10-10.3.9-1.1.8.cpanel.x86_64
EIGioncube-6.0.5-14.x86_64
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Same issue here.

@cPanelLauren My results show ionCube is installed for 7.2 and 7.3 but still getting same error as @cosmos64 .
Code:
ea-php70-php-ioncube6-6.1.0-2.2.46.cpanel.x86_64
cpanel-php72-ioncube-10.2.2-1.cp1176.x86_64
ea-php72-php-ioncube10-10.3.9-1.1.8.cpanel.x86_64
ea-php71-php-ioncube10-10.3.9-1.1.7.cpanel.x86_64
ea-php56-php-ioncube6-6.1.0-2.2.49.cpanel.x86_64
ea-php55-php-ioncube6-6.1.0-2.2.41.cpanel.x86_64
ea-php73-php-ioncube10-10.3.9-1.1.8.cpanel.x86_64
EIGioncube-6.0.5-14.x86_64
Hello,

Can you tell me about the system and php version the site is running? Are you using CloudLinux and their AltPHP?
 

mcgwier

Registered
Feb 5, 2020
2
0
1
Austin, Texas
cPanel Access Level
Root Administrator
My system has MultiPHP installed so I deleted the custom php.ini (through cPanel > Software > PHP Selector) and added the manual override in htaccess. That solved the issue until I can update or remove MultiPHP.

Thanks for the rapid response!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @mcgwier

I'm really glad the issue is resolved.

So some clarification on why this was occurring might be helpful, this issue happens when you're running on CloudLinux's alt-php without the altphp version of ioncube module loaded in the php.ini being referenced.

In order to resolve the issue you'd have to use only alt-php (php selector) extensions/modules or only ea-php (MultiPHP) modules/extensions. Also, note that MultiPHP is not removable like PHP Selector is.