The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ioncube loaders no longer work

Discussion in 'General Discussion' started by bvanderw, Jul 6, 2007.

  1. bvanderw

    bvanderw Member

    Joined:
    Mar 5, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I am using WHM 11.2.0 cPanel 11.6.0-R15021.

    When I went to bed last night, the IonCube loaders that I have been using for years were working fine. When I got up this morning, they no longer worked on multiple applications. We were running PHP 4.4.7, so I rebuilt Apache with 4.4.2, but they still fail.

    Any ideas what might be going on?
     
  2. viptexting

    viptexting Well-Known Member

    Joined:
    Sep 19, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Can you post the end of your php.ini
     
  3. bvanderw

    bvanderw Member

    Joined:
    Mar 5, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Is this what you are looking for?

    [Zend]
    zend_optimizer.optimization_level=15
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-2.5.10
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-2.5.10
    zend_optimizer.version=2.5.10a
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
     
  4. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    You do not have the path to your loader directory which is why viptexting asked to see your php.ini

    You would need to locate where the loaders are and add a path to it at the very top of your zend directives list in your php.ini.

    It should look something like this, or perhaps you can look at a previous backup of your php.ini

    zend_extension = /usr/local/ioncube/ioncube_loader_lin_4.4.so
     
    #4 jayh38, Jul 6, 2007
    Last edited: Jul 6, 2007
  5. bvanderw

    bvanderw Member

    Joined:
    Mar 5, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    That's not how I have been using IonCube. I have been using runtime loading for years by placing an ioncube directory in the directory holding the application.

    Like I said, this started failing overnight, so I'm wondering if this was the result of a CPanel update?
     
  6. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Stupid me for not mind reading. My bad.
     
  7. bvanderw

    bvanderw Member

    Joined:
    Mar 5, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    jayh38 - sorry to not give you all the info up front. I appreciate your help. Your solution does work, but what happens if someone on the server actually needs the Zend extensions?

    Our provider came up with perhaps a better solution (evidently they were seeing this on multiple servers). The php.ini had a weird non-existent directory location for the extension_dir variable. We actually created that directory and then dropped the ioncube loaders there. That worked.

    Still a mystery, though, as to what broke the runtime loading.

    Thanks...
     
  8. velda

    velda Well-Known Member

    Joined:
    Aug 24, 2005
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Utah
    Has anyone else seen this? Got a new server thats giving me grief with the loader. Only creating the funky directory (a step no other servers have needed) doesn't help, nor does changing the extensions directory in the php.ini (still looks for it in that other dir)
     
  9. viptexting

    viptexting Well-Known Member

    Joined:
    Sep 19, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Zend extensions work fine alongside Ioncube.

    Most of our servers have both installed:

    Typical php.ini:
    phpinfo() reports:
    Works fine with Zend platform too...
    AFAIK you can have as many zend_extension definitions as are required.

    According to the ioncube documentation, the php.ini method is more effecient too.
     
  10. leat

    leat Member

    Joined:
    Jul 23, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    In your php.ini, change

    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20020429"

    to

    extension_dir = "./"
     
  11. neonix

    neonix Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    124
    Likes Received:
    2
    Trophy Points:
    0
  12. rogerl

    rogerl Registered

    Joined:
    Jul 22, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Looks like this has broken APC extensions too
     
  13. benfish

    benfish Well-Known Member

    Joined:
    Feb 26, 2007
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    0
    Having the same problem too

    Im having the same problem too, and when i try install ioncube i just get misconfiguration errors :( (probably something with the way im doing it)

    What would cpanel have updated which would have caused this... and why?

    Ben.
     
  14. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    I do not understand this. Zend extensions will work fine with exception of perhaps php accelerators.
     
  15. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    We also had this problem on all our servers today, caused by the last cpanel update i guess but doesn't affect servers where ioncube is installed server wide..
    To install server wide, we created a new dir /usr/local/ioncube and put the loaders in it, then edited /usr/local/Zend/etc/php.ini Note that the loader must match your php version.
    Code:
    [Zend]
    zend_extension=/usr/local/ioncube/ioncube_loader_lin_5.2.so
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.2
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.2
    zend_optimizer.version=3.2.2
    Restarted Apache, all fixed :)
     
  16. ethix

    ethix Active Member

    Joined:
    Dec 21, 2004
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    yes it has broke mine :(
    i reinstalled APC (latest version) no luck so far
     
  17. ethix

    ethix Active Member

    Joined:
    Dec 21, 2004
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    it would help if i could read lol, the above has fixed my issue *touch wood*
     
  18. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    For reference, check the "enable_dl" setting in your PHP.INI

    If this setting is set to "Off" then you can't load dynamic loaders at runtime
    and that would be the reason that your ioncube stopped working.

    Now with that said, it is actually preferable to leave that setting "Off" as it is
    more secure and simply load ioncube as an extension from within the PHP.INI.
     
  19. abrender

    abrender Active Member

    Joined:
    Dec 5, 2002
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    We had our extension_dir in php.ini set to a non existant directory instead of "./" - we reset it back to "./" but cpanel again reset it. Anyone know how to stop this?
     
  20. benfish

    benfish Well-Known Member

    Joined:
    Feb 26, 2007
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    0
    :s

    Eeek..

    I have tried editing my /usr/local/lib/php.ini
    And my /usr/local/Zend/etc/php.ini

    (zend part looks like this now)
    zend_extension=/usr/local/ioncube/ioncube_loader_lin_4.4.so
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.0.1
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.0.1
    zend_optimizer.version=3.0.1
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so

    it doesnt work, and i dont know what is wrong :S

    (php version 4.4.7 :), path is correct and i dont think i should be using the TS one because it doesnt ask for it)

    "Site error: the file /home/clifish/public_html/index.php requires the ionCube PHP Loader ioncube_loader_lin_4.4.so to be installed by the site administrator."

    Happening on both of my servers now...
    Any help would be nice :)

    Edit: Fixed, thanks :)
     
    #20 benfish, Jul 8, 2007
    Last edited: Jul 8, 2007
Loading...

Share This Page