The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ioncube not loading after upgrade of zend

Discussion in 'General Discussion' started by Belaird, May 22, 2007.

  1. Belaird

    Belaird Well-Known Member

    Joined:
    Jun 24, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    I recently upgrade PHP to 5.2.1, rand zend installer for 3.2.8, but not I have a problem with Ioncube not loading. What I was able to gather so far, it indicated that I am using the the wrong version of IONCUBR with zend, but I don't know how to upgrade it to a compatable version.

    Here is my php info

    I then did an LS of ioncube

    Can someone direct me how to get the right version of ioncube running?
     
  2. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth
    Yes, you are using worng version of Ioncube. The Ioncube loaders that you have have loaded in php.ini are for PHP4 where you are running PHP5. You need to add new loader in /usr/local/Zend/etc/php.ini file.

    In order to do this, copy ioncube-loader-helper.php file from /usr/local/ioncube to any of your working domain's public_html and browse it as http://yourdomain.com/ioncube-loader-helper.php. It will guide you for the rest of the process and also specify the correct loader for your PHP version.
     
    #2 WebScHoLaR, May 23, 2007
    Last edited: May 23, 2007
  3. Belaird

    Belaird Well-Known Member

    Joined:
    Jun 24, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Ioncube Loader

    Thank for your help. I found where to get the installer and fixed ioncube
     
    #3 Belaird, May 23, 2007
    Last edited: May 23, 2007
Loading...

Share This Page