The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ioncube not working

Discussion in 'General Discussion' started by its_joe, Aug 18, 2007.

  1. its_joe

    its_joe Well-Known Member

    Joined:
    Feb 15, 2007
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    We have CenOS with WHM 11 on the server. We have php 5.1.6 on server too.

    Now I wan to install ioncube in it. I followd all the steps of
    http://www.webhostgear.com/77.html
    for how to install ioncude . But I am getting error.

    I have ioncube directory in /usr/local of server.
    In php.ini I have added following line
    zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.1_ts.so

    But still ioncube is not install and it gives me following error:
    ==================================================
    # php -v
    Failed loading /usr/local/ioncube/ioncube_loader_lin_5.1_ts.so: /usr/local/ioncube/ioncube_loader_lin_5.1_ts.so: undefined symbol: ts_allocate_id
    PHP 5.1.6 (cli) (built: Aug 18 2007 01:23:46)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with Zend Extension Manager v1.0.11, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.2.0, Copyright (c) 1998-2006, by Zend Technologies
    ======================================================

    Please suggest me what mistake I am doing .

    Thanks.
    its_joe
     
  2. its_joe

    its_joe Well-Known Member

    Joined:
    Feb 15, 2007
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    I got the solution for this error. The following should be there in php.ini in the [Zend] section. The following is the correct entry
    ========================================================
    [Zend]
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.0
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.0
    zend_optimizer.version=3.2.0
    zend_extension=/usr/local/ioncube/ioncube_loader_lin_5.1.so
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
    ============================================================

    Earlier I was mentioning the ioncube entry after ZendExtensionManager like this way. The following is the incorrect entry
    ======================================================
    [Zend]
    zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.0
    zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.0
    zend_optimizer.version=3.2.0
    zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
    zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
    zend_extension=/usr/local/ioncube/ioncube_loader_lin_5.1.so
    ========================================================

    Mentioning /usr/local/ioncube/ioncube_loader_lin_5.1.so after ZendExtensionManager creates the problem . So just mentionthe ioncude above ZendExtensionManager and the issue gets fixed.

    Thanks for reading this.

    its_joe
     
  3. koolcards

    koolcards Well-Known Member

    Joined:
    Oct 8, 2003
    Messages:
    146
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Tampa, Fl
    Actually, it looks like you were trying to use the Threaded version ("ts.so") where your correct, working version doesn't:
    If your <?php phpinfo(); ?> shows:
    "Thread Safety disabled"

    then your PHP isn't threaded and you'll want to use the 'source' files (".so") rather than the 'thread safety source' files ("ts.so")
     
  4. its_joe

    its_joe Well-Known Member

    Joined:
    Feb 15, 2007
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    Even if you use /usr/local/ioncube/ioncube_loader_lin_5.1.so in php.ini after the line of ZendExtensionManager it don't work. Anf if you try to start the apache it will give error OR you will face some other error for php.

    The important thing here is to mention the line /usr/local/ioncube/ioncube_loader_lin_5.1.so after ZendExtensionManager in php.ini.

    I am new to this. If I am wrong than please correct me. So that i will know more about ioncube.

    :D
     
  5. koolcards

    koolcards Well-Known Member

    Joined:
    Oct 8, 2003
    Messages:
    146
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Tampa, Fl
    Which I think is a misstatement where you meant to say 'before' the ZendExtensionManager. And that's correct. I add the
    toward the top of my php.ini under "; Language Options ;", well above the [Zend] section way at the bottom, because the ioncube install documentation says:
    and way at the top I know I'm ahead of them. :cool:

    But your original error message was that you were using the wrong ioncube file:
    None of which matters now that you have the correct file loading above the other zend_extension entries ;)

    Look. I get to play with the fonts! :D
     
  6. its_joe

    its_joe Well-Known Member

    Joined:
    Feb 15, 2007
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    0
    :):)

    Thanks for the information. this forum is really a sea of knowledge.

    :D
     
Loading...

Share This Page