The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ioncube / php.ini

Discussion in 'General Discussion' started by taproot, Sep 22, 2008.

  1. taproot

    taproot Well-Known Member

    Joined:
    Aug 22, 2008
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Having some trouble getting ioncube running so I can install whmcs.

    Ioncube wants me to edit the php.ini file and add:
    zend_extension = /<path>/ioncube_loader_lin_5.2.so
    before any other zend_extension entries. Well I don't currently see any zend_extensions entries which i guess is fine?

    and my second question is if I manually edit the php.ini file will it be overwritten later by WHM when I make changes via my control panel?

    Or is there a better/easier way to setup the ioncube loader?

    Cheers,
    TR
     
  2. taproot

    taproot Well-Known Member

    Joined:
    Aug 22, 2008
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Awesome! Thank you. I have been using cpanel for about 48 hours now so still finding things everywhere.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Isn't that a WHM plugin? If so, you should simply need to select WHM > Tweak Settings > Loader to use for internal cPanel PHP > ioncube
     
  4. ashokpomnar

    ashokpomnar Active Member

    Joined:
    Sep 30, 2006
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    You can easily install IonCube using following command via SSH shell

    /scripts/phpextensionmgr install IonCubeLoader
     
  5. taproot

    taproot Well-Known Member

    Joined:
    Aug 22, 2008
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    glad you posted that as the other option did not work and this one did. Not sure why really, but thanks!
     
Loading...

Share This Page