The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ioncube problem

Discussion in 'EasyApache' started by Motamedi, Aug 2, 2015.

  1. Motamedi

    Motamedi Well-Known Member

    Joined:
    Mar 14, 2015
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iran , Tehran
    cPanel Access Level:
    Root Administrator
    Hello ,

    my problem is

    Site error: the file /home/user/public_html/shop requires the ionCube PHP Loader ioncube_loader_lin_5.3.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

    All scripts WHMCS have this problem

    IonCube Loader 4.7.5 for PHP installed to EasyAapache and that php configuration editor , zend_extension is "/usr/local/IonCube/ioncube_loader_lin_5.3.so, /usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so"

    Please help me for solved this problem

    thanks
     
  2. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    The script wants PHP 5.3 with ionCube but you have PHP 5.4.

    Consider using something like "ntphpselector" and choose 5.3 for this specific account.
     
  3. ioncube

    ioncube Member

    Joined:
    Dec 22, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Unfortunately the advice from ModServ is incorrect. The PHP script says that you need the Loader for PHP 5.3. This means that your server is running PHP 5.3 and that the Loader is either not installed or else not installed correctly. You might have the wrong Loader, the Loader is in the wrong place, an incorrect php.ini file was edited etc. The Loader that you say you have is also not the latest.

    We would recommend using the latest Loader from the series 5 Loaders, currently 5.0.14, which you can get from http://get-loader.ioncube.com There is also a script called the Loader Wizard that can assist with Loader installation.

    version 5 Loaders also include support for a new service called ionCube24. You can signup for free at ioncube24.com, and this gives free intrusion protection to websites using PHP. Unlike scanners that look and warn of possible vulnerabilities but that do nothing to actually prevent any security compromise, ionCube24 actively blocks any unexpected code in real-time before it does any damage, and also alerts you in real-time. This gives protection against vulnerabilities that are not even known about yet by scanners, but that may well be known about by hackers. As an example, Kayako only recently fixed a security flaw that had been exploited by hackers for years where files could be created remotely, and ionCube24 blocked such files (we know this from our own experience of using Kayako on our helpdesk server and attack attempts from hackers). Other features are also being added to ionCube24 that will be useful to anyone running a website, so using Loader 5, even if not needing to run encoded files, is a good advantage.

    Loader 5 is also more efficient when using ionCube24 because it caches knowledge of which files are encoded and which are not, and completely bypasses normal Loader checking for a file being encoded when it already knows that it isn't.

    Hope this helps!
     
  4. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    Yes my bad, I misread the version number, thanks for clearing that up (Y)
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    To elaborate on this, I often see this issue when an individual php.ini file is uploaded to the account, and it's not modified after upgrading PHP. I suggest checking to see if the account has it's own php.ini file and moving it out of the way to ensure the account uses /usr/local/lib/php.ini.

    Thank you.
     
Loading...

Share This Page