cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
Hey hey! At this time, never, as IonCube hasn't released support for PHP 8, and from the chats I see from its developers, they may not:

 
  • Like
Reactions: cPanelAnthony

avinash.pudota

Active Member
Jan 27, 2013
40
4
58
India
cPanel Access Level
Root Administrator
As per their blog post, it is almost ready
However, 8.0 will not be supported but 8.1 will be supported.
 

Esquio

Member
Feb 29, 2016
23
5
53
Spain
cPanel Access Level
Root Administrator
As per their blog post, it is almost ready
However, 8.0 will not be supported but 8.1 will be supported.
So this would be a cPanel feature.
 

raisulmushfeq

Registered
Dec 28, 2019
2
1
3
Bangladesh
cPanel Access Level
Root Administrator
Accoring to their 5 August update:
5TH AUGUST UPDATE: Online Encoder has been updated with PHP 8.1 encoding support. Version 12.0.0 Loaders now available (Linux only for now, other operating systems will follow soon after).
I am not super familiar with ioncube, but does that mean cPanel will start to implement it now with 8.1?
 
  • Like
Reactions: Esquio

PPNSteve

Well-Known Member
Mar 13, 2003
422
9
168
Somewhere in Ilex Forest
cPanel Access Level
Root Administrator
Twitter
Add me to the list of those who are also wondering (and wanting this) about getting it added to EA

12th Aug 2022 - Encoder version 12.0.0

Encoder version 12, with support for PHP 8.1 has now been released. There are accompanying version 12 loaders.
 
  • Like
Reactions: cPRex

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
@mavi0606 - IonCube is not automatically included with PHP so you'd need to install that separately. In EasyApache you'll find a version of IonCube for PHP 8.1. Just toggle the switch on the right and complete the EasyApache build and it will be installed to your profile.

Screen Shot 2022-11-21 at 10.51.19 AM.png