IonCube - Updating ISSUE - Plz help me

rohit09

Well-Known Member
Dec 10, 2010
61
0
56
; Directory in which the loadable extensions (modules) reside.
extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20060613"
zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.3.so"
extension="eaccelerator.so"
eaccelerator.cache_dir="/tmp/eaccelerator"
eaccelerator.check_mtime="1"
eaccelerator.compress="1"
eaccelerator.compress_level="9"
eaccelerator.debug="0"
eaccelerator.enable="1"
eaccelerator.filter=""
eaccelerator.optimizer="1"
eaccelerator.shm_max="0"
eaccelerator.shm_only="0"
eaccelerator.shm_prune_period="0"
eaccelerator.shm_size="16"
eaccelerator.shm_ttl="0"
extension="suhosin.so"
Is it looks Ok? Guess what when I type php -v on my root i got

PHP: syntax error, unexpected '=' in ................../php.ini on line 792
PHP 5.3.4 (cli) (built: Mar 3 2011 21:02:47)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with the ionCube PHP Loader v3.3.20, Copyright (c) 2002-2010, by ionCube Ltd.
See.. It's still being old Version! Plz help me ! :(

How to fix this >> :(
 

JaredR.

Well-Known Member
Feb 25, 2010
1,834
25
143
Houston, TX
cPanel Access Level
Root Administrator
The 5.3, in the extension filename /usr/local/IonCube/ioncube_loader_lin_5.3.so, refers to the version of PHP, not the version of IonCube. If you download and extract the archive from PHP Encoder, protection, installer and performance tools from ionCube: Loader Download, you will see extension files for several different PHP versions:

Code:
# wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz
--2011-03-04 08:33:42--  http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz
Resolving downloads2.ioncube.com... 64.85.170.46
Connecting to downloads2.ioncube.com|64.85.170.46|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2672940 (2.5M) [application/x-gzip]
Saving to: `ioncube_loaders_lin_x86.tar.gz'

100%[==================================================================================================================================================================>] 2,672,940   1.12M/s   in 2.3s    

2011-03-04 08:33:45 (1.12 MB/s) - `ioncube_loaders_lin_x86.tar.gz' saved [2672940/2672940]

# tar zxvf ioncube_loaders_lin_x86.tar.gz 
ioncube/
ioncube/ioncube_loader_lin_4.3_ts.so
ioncube/ioncube_loader_lin_5.2_ts.so
ioncube/LICENSE.txt
ioncube/loader-wizard.php
ioncube/ioncube_loader_lin_4.4_ts.so
ioncube/ioncube_loader_lin_5.1_ts.so
ioncube/ioncube_loader_lin_5.0.so
ioncube/ioncube_loader_lin_5.1.so
ioncube/ioncube_loader_lin_5.3_ts.so
ioncube/ioncube_loader_lin_5.2.so
ioncube/ioncube_loader_lin_4.2.so
ioncube/README.txt
ioncube/ioncube_loader_lin_5.0_ts.so
ioncube/ioncube_loader_lin_4.3.so
ioncube/ioncube_loader_lin_4.4.so
ioncube/ioncube_loader_lin_4.1.so
ioncube/ioncube_loader_lin_5.3.so
You are using PHP 5.3, so /usr/local/IonCube/ioncube_loader_lin_5.3.so is the correct extension file for your version of PHP.