IONCUBE will not run after php upgrade

superiorhost

Well-Known Member
Nov 16, 2001
77
0
306
cPanel Access Level
Root Administrator
I have upgraded php to 5.2.3, turned on phpsuexec, and have just one major issue to solve.

ioncube is no longer working.

[email protected] [~]# php -v
Failed loading /usr/local/ioncube/ioncube_loader_lin_5.2.so: /usr/local/ioncube/ioncube_loader_lin_5.2.so: cannot open shared object file: No such file or directory
PHP 5.2.3 (cli) (built: Aug 31 2007 22:20:07)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
with Zend Extension Manager v1.0.9, Copyright (c) 2003-2006, by Zend Technologies


It was located in a users site. Now,I moved it to /usr/local so I could turn off the dl function. However, it wasn't working before I moved it either...

Any thoughts? This is kinda urgent. I have 6 more servers to do the same with, and need ioncube on most of them.

Also, is this version of PHP too high of a move from 4.4.4? or should it be stable. I was told by the techs that there is an issue with zend that may be causing this. However, zend looks like it is fine.

Thank you,
Tim L
 

superiorhost

Well-Known Member
Nov 16, 2001
77
0
306
cPanel Access Level
Root Administrator
hi,
Thanks. yes, i have it before the first zend entry in the ini file. I tried it up at the top of the file, and down at the bottom bove the zend items... neither worked.

The tech got it fixed last night, so i am waiting to hear what he did to get it going.

Thanks.
Tim L
 

jayh38

Well-Known Member
Mar 3, 2006
1,212
0
166
Curious if you have a eaccelerator installed. If so, they may have disabled it for now to get it working.