mpallo

Registered
Jul 29, 2006
4
0
151
Still frustrated with not being able to get this to work on the built in iOS mail app. My web host provider is running 74 and says it is working on his iPhone using the Outlook app. Somewhere along the 11.x iOS update releases this stopped working after working perfect for months. I was hoping the iOS 12 release would have fixed this. I updated to iOS 12 on Monday and push immediately started working for a couple minutes then stopped. I have all the push options in my mail config on the phone. The only time it will work is if you are on the home screen or have the mail app open. Otherwise it will not pull down any mail at all until you open the app.

Has anyone gotten this resolved? Have been looking at hosted Exchange because I really want the instant mail.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello @mpallo,

Can you confirm if you are testing with an individual email account? If not, and if you are instead using the cPanel account's default email user, then be sure to enter [email protected], not [email protected] in your email client. There's some discussion of this on the following thread:

Configure IOS Push Mail Function?

I look forward to your response.

Thank you.
 

mpallo

Registered
Jul 29, 2006
4
0
151
Hello @mpallo,

Can you confirm if you are testing with an individual email account? If not, and if you are instead using the cPanel account's default email user, then be sure to enter [email protected], not [email protected] in your email client. There's some discussion of this on the following thread:

Configure IOS Push Mail Function?

I look forward to your response.

Thank you.
Hi,

Thanks for responding. Yes, it is an actual individual email account I have setup. In fact the behavior is the same with all of the accounts I am testing. I can confirm it works with the Outlook app and other 3rd party mail programs but simply cannot get it to stay persistent on the native iOS mail client.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Thanks for responding. Yes, it is an actual individual email account I have setup. In fact the behavior is the same with all of the accounts I am testing. I can confirm it works with the Outlook app and other 3rd party mail programs but simply cannot get it to stay persistent on the native iOS mail client.
Hello @mpallo,

Could you open a support ticket so we can take a closer look at your system and see if there's anything that could potentially result in the iOS push feature not working as expected? You can post the ticket number here and we will update this thread with the outcome.

Thank you.