The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IP address disappeared...

Discussion in 'General Discussion' started by 4u123, Mar 12, 2006.

  1. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Any idea why an IP would suddenly stop working ?

    A site was switched to a new ip ages ago and an ssl cert setup on it.

    Yesterday - suddenly the site is not accessable. When I viewed the Ip address usage, the IP for that site did not appear.

    If I tried to add the IP it said it was already added. I rebuilt the ip pool - this had no effect.

    Finally, I removed the IP form the server and added it again - voila! Site is back up and running fine.

    My concern is that this could happen again - any idea why this would happen ?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you running CentOS v4.2/RHEv4.2? Some people have reported issues with /etc/init.d/ipaliases not running at bootup on those OS versions (ipaliases assigns the IP's to the virtual NIC devices). If that is the issue, then adding the above script to the end of /etc/rc.d/rc.local should resolve the issue.
     
  3. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    No, I just updated APF and switched antidos on.

    If I do "view / delete IP addresses" - it comes up in the colour red. If I delete it and add it again it works for a while then the customer tells me his site has gone again - very strange.

    Mar 12 20:14:02 SERVER antidos(27864): alias interface ip.ip.ip.ip unbound.

    I'm not sure whether that log entry is antidos saying it has unbound the IP itself - or whether it is saying the ip has become unbound by another process.

    Message log says...

    Mar 12 20:32:46 SERVER named[2835]: no longer listening on ip.ip.ip.ip#53

    Theres nothing significant before that.

    EDIT.. 22:23pm same day Happened again just now.

    EDIT... Disabled antidos on that server and the problem hasnt happend again. Why would it unbind the IP ? Ive found this new antidos very useful on other servers while i dont have a hardware firewall in place and I'd like to use it on all of them if poss - I guess I need to contact rfx.

    Any ideas ?
     
    #3 4u123, Mar 12, 2006
    Last edited: Mar 13, 2006
Loading...

Share This Page