The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IP Deny Manager not working!!

Discussion in 'General Discussion' started by JohnJacobes, Sep 27, 2003.

  1. JohnJacobes

    JohnJacobes Member

    Joined:
    Aug 31, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Apparently my IP Deny Manager is not working correctly. I mean, I add all of the IP's and domains, but it doesn't really ban anything. All the IP's I have banned, the users of those IP's are able to successfuly get in. We think it's a .htaccess file problem, so please help us figure out why it's not working. :(

    cPanel.net Support Ticket Number: retarded people are getting in my site :(
     
  2. JohnJacobes

    JohnJacobes Member

    Joined:
    Aug 31, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Eeek.. sorry I thought where it said Support Ticket Number, it said Topic Description. I use Invision Board.. sorry about that. However, please someone help me on this. :(

    cPanel.net Support Ticket Number:
     
  3. Angel78

    Angel78 Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    413
    Likes Received:
    1
    Trophy Points:
    16
    perhaps they are using Proxy servers...

    cPanel.net Support Ticket Number:
     
  4. JohnJacobes

    JohnJacobes Member

    Joined:
    Aug 31, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    No they are not.. I did checks.

    cPanel.net Support Ticket Number:
     
  5. Jemshi

    Jemshi Well-Known Member

    Joined:
    Sep 11, 2003
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    I assume you are doing this for a domain from its control panel. Look in your public_html to see if a .htaccess file is created there with something like this.

    deny from IP

    the feature works fine for us :)

    By the way, is this a frontpage enabled site ?

    cPanel.net Support Ticket Number:
     
  6. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    18
    I have a FrontPage enabled site with the IP deny not working properly. Anyone else having this issue?

    cPanel.net Support Ticket Number:
     
  7. kardukov

    kardukov Active Member

    Joined:
    Sep 15, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Russian Federation
    I manually added deny directive in .htaccess file.

    But I can access to the site.

    AllowOverrite All.

    So, it not work.

    cPanel.net Support Ticket Number:
     
  8. Jemshi

    Jemshi Well-Known Member

    Joined:
    Sep 11, 2003
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    frontpage has no option to set this ? we should not modify the .htaccess manually which are made by frontpage. This breaks frontpage access - so there should be option to set IP deny from frontpage.

    cPanel.net Support Ticket Number:
     
  9. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    18
    FrontPage does not have that option. Unless I am looking at the wrong place.

    The other thing is that when the IP Deny is working, the custom 403 error page does not show up. Even though it is sepcified in htaccess... any ideas?

    cPanel.net Support Ticket Number:
     
  10. rbrown

    rbrown Active Member

    Joined:
    Jun 11, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Yes, this has never worked for me either. This is just a cPanel bug that has never been tested or verified by cPanel's staff. Let me provide a little more details:

    I'm not sure if you would say it's a problem with "Frontpage (re)install" or with the "IP Deny Manager", but the problem is caused by a broken .htaccess configuration installed from FP Extensions. To fix the buggy .htaccess configuration, simply UNinstall Frontpage extensions and the bugs get deleted with it. (Never ever install frontpage extensions again or the bug will come back). Then whatever IPs you add using cPanel's "IP Deny Manager" will be banned perfectly. (You just need to add them again since uninstalling frontpage takes everything with it into the bit-bucket.)

    If you want frontpage installed AND want to use IP Deny Manager, then you can add a cron using the "Stanard Cron Job Manager" to undo the cPanel bugs as follows:

    * * * * * perl -p -i -e 's/deny,allow/allow,deny/' ~/public_html/.htaccess

    Or set it to run every hour or every day or whatever. Or you can just run this perl line from command prompt after every time you install frontpage extensions. Running this command will perform the following repairs:

    OLD EVIL:
    order deny,allow

    NEW GOOD:
    order allow,deny

    I'm surprised that Jemshi didn't just say that this is a bug instead of pretending like everything was working. I guess Jemshi just didn't have FrontPage enabled when testing.

    Hopefully, someone is strong enough to convince Nick to repair the "IP Deny Manager" to start fixing the order command on-the-fly to ensure that "deny" is LAST in order to force the deny settings to override any allow settings.

    cPanel.net Support Ticket Number:
     
  11. wills

    wills Well-Known Member

    Joined:
    Jan 29, 2003
    Messages:
    202
    Likes Received:
    1
    Trophy Points:
    18
    Well this is certainly a great help. Thank you!

    cPanel.net Support Ticket Number:
     
  12. rbrown

    rbrown Active Member

    Joined:
    Jun 11, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Re: Re: IP Deny Manager not working!!

    Oh, and of course that "deny from all" might cause problems for those that are not explicitly banned. Better try this command instead:

    perl -p -i -e 's/deny,allow/allow,deny/;s/^(d.*\ball)$/#$1/' ~/public_html/.htaccess

    Sorry bout that :-D

    cPanel.net Support Ticket Number:
     
  13. rbrown

    rbrown Active Member

    Joined:
    Jun 11, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Yes, I've been having the same problem.

    You cannot see the custom 403.shtml because that page is ALSO denied for the same reason that the other page you were trying to access. You probably see that "ADDITIONALLY" error which means apache hit another error while trying to catch the first error. It shows that "ADDITIONALLY" error to avoid an infinite loop.

    You can fix this by putting these lines somewhere in the ~/public_html/.htaccess for each user:

    Code:
    <Files ~ 403.shtml>
    order allow,deny
    allow from all
    </Files>
    
    but if you have root access on the server, you can fix EVERYONE on the entire machine by putting this somewhere in /usr/local/apache/conf/httpd.conf:

    Code:
    <Location /403.shtml>
    order deny,allow
    allow from all
    </Location>
    
    Then the changes don't get wiped every time someone installs Frontpage. Wouldn't it be nice if cPanel just put that in the httpd.conf automatically like all that other stuff they put in there?

    cPanel.net Support Ticket Number:
     
  14. wizzard52269

    wizzard52269 Member

    Joined:
    Oct 12, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thanks!

    Thanks,

    I was having the same problems.

    cPanel.net Support Ticket Number:
     
  15. Rich Z

    Rich Z Member

    Joined:
    Dec 28, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ah!

    So tell me, is here any RISK associated with uninstalling the front page extensions from a live domain? I'm not running FrontPage, but there is a very active vBulletin message board on there that I don't want to screw around with.

    Thanks for the help!
     
Loading...

Share This Page