Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

IP - Licence issue

Discussion in 'General Discussion' started by Tsafarog, Nov 26, 2010.

  1. Tsafarog

    Tsafarog Member

    Joined:
    Oct 23, 2009
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    53
    Hello,

    I have a Centos with Cpanel/WHM server and i have had an issue with Main ip address and licence validation that i overlooked since the problem occured only on server restarts that are not often.

    After the newest upgrade thou my issue reproduces after ./scripts/upcp as well.

    The problem:

    I have 4 interfaces eth0, eth0:1, eth0:2, eth0:3

    The first 3 interfaces were created once i got the server manually via SSH. The last one was added through WHM

    eth0 is my main/shared ip address (with valid licence)
    eth0:1 and eth0:2 are my nameservers
    eth0:3 was created for non shared ip website.

    Whenever i had to reboot server i was getting the message that this server doesnt have a valid cpanel licence and when i i used /usr/local/cpanel/cpkeyclt to validate, the script was checking eth0:1 instead of eth0.

    By doing a "service network restart" and running again /usr/local/cpanel/cpkeyclt everything was getting back to normal.

    I ignored that error in the past because it was only occuring after server reboots that were not often but now i get it after every upcp.

    I have double checked my hosts file, my WHM config, ifcfg files and everything seems to be in order .....

    Is there something else i need to check?

    Thank you in advance
     
    #1 Tsafarog, Nov 26, 2010
    Last edited: Nov 26, 2010
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice