The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IP missing / not useable?

Discussion in 'General Discussion' started by Secret Agent, Feb 7, 2005.

  1. Secret Agent

    Secret Agent Guest

    Not sure why but xx.x1.49.158 is not used at all, nor reserved in WHM’s IP usage list. Not one domain is using it at all yet it shows as free in WHM’s “show IP address usage”,
    but when I select it in a IP list for a domain it does not appear at all. Could you please explain why that is happening?

    I ran a few scripts hoping to fix this

    /scripts/fixnamed
    /scripts/fixbuggynamed
    /scripts/fixcommonproblems
    /scripts/fixetchosts
    updatedb

    Ran “rebuild the IP address pool” in WHM as well, oddly it won’t appear.

    Any help would be appreciated.
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    What do these yield.

    In ssh
    ifconfig -a|grep xxx.xxx.xxx.xxx <--xxx= IP

    cd /etc
    grep xxx.xxx.xxx.xxx *
     
  3. Secret Agent

    Secret Agent Guest

    root@server [~]# ifconfig -a|grep xx.x1.49.158
    inet addr:xx.x1.49.158 Bcast:xx.x1.49.255 Mask:255.255.255.0


    root@server [/etc]# grep xx.x1.49.158 *
    ipaddrpool-:xx.x1.49.158
    ips:xx.x1.49.158:255.255.255.0:xx.x1.49.255
    ips.dnsmaster:xx.x1.49.158:255.255.255.0:xx.x1.49.255
    nameserverips:xx.x1.49.158=0
     
  4. Secret Agent

    Secret Agent Guest

    I added the IP to the ipaddresspool and then attempted to use it.

    Says:

    "xxipaddressxx" is in use by another domain name and is not a shared ip.

    I do not understand. No other domain/account is using that IP at all. Any help on this would be appreciated.
     
  5. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Well from the commands you ran it is bound to the nic card and should be fully usable. Try removing the IP and readding it.
     
  6. Secret Agent

    Secret Agent Guest

    Very odd...

    eth0:13 is now up. xx.x1.49.158/255.255.255.0 broadcast xx.x1.49.255 has been added
    System has 1 free ips.


    Now, it already had 1 free IP (another IP) yet it still shows as still one free IP.

    Attempted to change an account to this problem IP and once yet again, does not appear in the list.
     
  7. Secret Agent

    Secret Agent Guest

    Can anyone please help me? This is the first time I've ever encountered such an odd issue with IP's. Any help would be appreciated.
     
  8. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    The best option to try would be to completely remove the IP from the system and try to readd.

    In WHM, remove/delete the ip.

    Check with ifconfig command to ensure it is down.

    Then in /etc/ remove it from the following files

    ipaddrpool
    ips
    ips.dnsmaster
    nameserverips

    Do a grep through /etc/* to ensure it is not found. Now try readding throught WHM.

    Good Luck
     
Loading...

Share This Page