The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IP Resolving, Domains Aren't

Discussion in 'General Discussion' started by orty, Oct 6, 2005.

  1. orty

    orty Well-Known Member

    Jun 29, 2004
    Likes Received:
    Trophy Points:
    Bend, Oregon
    cPanel Access Level:
    Root Administrator
    IPs Resolving from Wget, etc..., Domains Aren't

    OK, unfortunately, I'm not a whiz at DNS stuff, so I don't know where to look. But here's the deal: Any request from my server that goes to a DOMAIN doesn't resolve (wget, smtp, curl, php includes, cron jobs, whatever). But if I change it to request the IP address, things work fine. Obviously, that's not ideal, and this just started happening today.

    Based on a couple other threads, I looked into the /etc/resolv.conf file, and pinged everything:
    I could not, however, get a ping reply on "". Don't know if that matters.

    But when I try to wget a site, I get this error:
    root@harborside [/etc]# wget
               => `index.html'
    Resolving failed: Host not found.
    And that domain's on the same server, even.

    Naturally, the person who's actually the billing contact on this server isn't available to submit a ticket with layeredtech (I basically handle the server when she's not available), so does anybody have any ideas what's going on? Her clients are harrassing me, so I'd like to get them off my back ;-)

    Edit: Forgot to mention, I did restart bind via WHM, and that didn't help things.

    Edit2: I'm still struggling with this. Restarted the named service, added some more name servers to my resolv.conf file, and even restarted the server (about 300 days of uptime) and I'm still getting errors.

    Edit3: OK, now this is getting weird, as it's very sporadic. After rebooting and still having trouble, I went and got something to eat. Came back, tried it again, still didn't work, but I could suddenly get other domains outside my server (which I couldn't do before). I wget just fine, but can't get or some other domains on my server (but I can get some of the, just not all). And some e-mails are still getting bounced back as unroutable.

    Anybody have any suggestions?
    #1 orty, Oct 6, 2005
    Last edited: Oct 7, 2005

Share This Page