The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ipcheck error email.

Discussion in 'E-mail Discussions' started by redcable, Jul 16, 2004.

  1. redcable

    redcable Active Member

    Joined:
    Jun 6, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    I recently had to restart apache and now i get this error, Im newbian to whm so i was hoping someone could tell me the exact steps to take to solve this problem.

    Thanks much guys,

     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Did you add the "A" entry for your host name? If so, resolv.conf should look something like:
    domain "server name"
    search "server name"
    name server 127.0.0.1
    name server "IP of name server #1"
    name server 'IP of name server #2"
     
  3. dorkon

    dorkon Registered

    Joined:
    Nov 6, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I too am receiving that ipcheck email.

    In my resolv.conf file, it reads:

    >>>>>>>>>>>>>>>>>>>>>>
    search localdomain
    nameserver [IP address of Nameserver]
    nameserver [IP address of Nameserver]
    >>>>>>>>>>>>>>>>>>>>>>

    My concern is why does it say "localdomain" (it literally says that word, it's not just me substituting in for my domain name) instead of actually reading as my domain name? And it doesn't have the domain part in it. Is this part of the reason I am having these problems and getting this IPCheck email? Apart from going into resolv.conf and changing the file manually, is there something that I've done wrong in WHM that I could fix from there?

    My other issue that I hypothesize is related is that when I click on "Modify Resolver Configuration" my primary nameserver is listed as 127.0.0.1. In the instructions above that, it says that I should enter in my two nameservers, which I do... but no matter how many times I do that and click "continue", when I go back into "Modify Resolver Configuration", it's back to 127.0.1. Any ideas?
     
  4. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Generally have edited resolv.conf by hand as the issue you mention of not seeing any changes when returning to the config page is something that so far has not been fixed by cPanel.
    There has been one change in the intervening months and that is to use the virtual/shared IP on your server instead of 127.0.0.1.
    HTH
     
  5. dorkon

    dorkon Registered

    Joined:
    Nov 6, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for the quick response... so I should just manually change my resolv.conf to match what you have above that will fix my problem?
     
  6. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    If you check /etc/hosts and also the zone file for this domain for accuracy along with the resolv.conf edits then most likely yes. The other possibility (less likely) is that your eth0 interface is not booting on the correct IP. In Linux you can check /etc/sysconfig/network-scripts.
     
  7. alexisb

    alexisb Active Member

    Joined:
    May 25, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Did you fix this?

    Hi guys, did you fix this error?

    I am also getting this email but I see my nameserver and domains working with no problem.

    Regards.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It's a bug in cPanel's ipcheck procedure. There are several threads running about it at the moment. I'm getting it on 4 servers and if you correct it, it breaks it again and then complains :rolleyes: I've no idea if anyone has reported it :p
     
  9. alexisb

    alexisb Active Member

    Joined:
    May 25, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    A bug

    Hi, thanks for your reply. I searched and saw many threads about this bug.

    The question would be: Is this affecting in any way DNS resolution or is just an email I can forget about?

    I've seen everything working normally so far.

    Regards.
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've been studiously ignoring it and not noticed any issues as yet ;)
     
  11. alexisb

    alexisb Active Member

    Joined:
    May 25, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Good, one more useless email in my inbox a day, I can live with that :)
     
  12. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    After updating cPanel to 9.9.9 I keep getting "unrouteable mail domain" whenever i send mail via php web forms to any remote email address, and I suspect this has something to do with my dns and/or resolv.conf and/or /etc/hosts.

    Can anyone correct the following if necessary:

    /etc/hosts has

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost
    12.34.56.78 servername.mydomain.com

    /etc/resolv.conf has

    domain mydomain.com
    search mydomain.com
    nameserver [IP of my primary ns]
    nameserver [IP of my secondary ns]

    (of course these have actual values on my server)

    Many thanks in advance for any assistance with this :)
     
    #12 jack01, Dec 23, 2004
    Last edited: Dec 23, 2004
  13. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    Code:
    12.34.56.78 servername.mydomain.com
    You should have 'servername' after that, so:

    Code:
    12.34.56.78 servername.mydomain.com servername
    However, it seems that cpanel has a bug (still) that will rewrite it incorrectly. So you'll have to keep changing it or doing a chattr +i on /etc/hosts


    Also, I understood that you didn't need the 'search mydomain.com' - it wasn't necessary.

    But it may also be that your dns is having problems... so check to make sure that your dns is responding to queries.
     
  14. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for the advice designguy.

    I added servername as you suggested but unfortunately the mail sending issue remains. (I have not removed the 'search' entry as it has always been like this and all used to work fine with it in).

    I am pretty sure that named/bind is up and ok, but do you have any particular test in mind?

    This is quite a distressing situation for me as all the forms on this server are failing to send mail out to remote email addresses since I updated cPanel/WHM a few days ago.

    HELP!..any help would be just fabulous!

    Thanks again.
     
  15. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    Is the setting for /etc/hosts still as you changed it or has cpanel automatically rewritten it? I believe there were problems using webmail if the servername wasn't there... not sure if it's the same for your issue though.

    Well, you can try manually querying your primary nameserver for the remote domains you're trying to mail to and see what it says. (Hint: you'd use the 'dig' command for that.)

    ALso, did you check the outgoing mail queue and are the mails stuck in there? Did you trying Deliver Now for some of them and see if there was an error from the remote server, or an error from your local system?
     
  16. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    It's OK, I spent along time trying upcp again and reinstalling sendmail etc, and finally it's all ok on that server now (phew!). Thanks for your input anyway designguy.

    BUT....

    NOW, on a different server I was getting the same ipcheck emails each day and I did as suggested somewhere in these forums i.e. chattr -i on /etc/hosts once I had corrected /etc/hosts. Well it all seemed ok last night immediately after the chattr -i, but today I find I'm not able to get into this box at all via SSH (the host is inreachable), using any of its IPs. Also, various urls local to this box that have been fine until today had started returning 403 forbiddens and internal server errors, and since then these same urls are all now just not respondingnot working' on this box with odd symptoms. I can telnet on port 25 which tells me relaying is not allowed, ok, but port 110 give no response. Ping and traceroute to the server work fine.

    I am now officially worried. I have sent a TT to my datacentre but...

    Any useful suggestions or advice will be very much appreciated.
     
    #16 jack01, Dec 26, 2004
    Last edited: Dec 26, 2004
  17. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Forget the last plea for suggestions, I rebooted the box using our DC reboot facility and all came back OK?! We'll I'm still flumoxed but I shall be looking into this weirdness.
     
  18. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    It should have been 'chattr +i' that you did... 'chattr -i' would remove the immutable flag.

    As to the rest of your weirdness... it sounds like your server 'froze' up somehow. I've heard of a process getting stuck 'asleep' and anything else it touches also falls 'asleep', until the server just needs a hard reboot to get it back up.
     
  19. jack01

    jack01 Well-Known Member

    Joined:
    Jul 21, 2004
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    16
    Hi designguy!

    Yes, I realize the chattr -i mistake, that's what comes of spending too much time worrying, losing sleep and reading forums!! And all this over the christmas hols!! hehe.

    Anyway, I'm really quite amazed that a sysadmin has to resort to something like a chattr to fix a bug in WHM/cPanel which surely could be relatively easily fixed by the programmers at cPanel? Do you have any ideas what the REAL problem is? As it stands I am refraining from applying the chattr +i to /etc/hosts because I am just plain suspicious now about whether it affects anything else, e.g. when upcp runs overnight could it have ramifications?

    Having spent ages also sorting out spamd problems (still blocks all mail when enabled on an account!!) I am now a little greyer in the hair for new year, and all because of 9.9.9 RELEASE. Nice.

    I'm just glad I got that other stuff fixed (for now). Happy new year to all!
     
    #19 jack01, Dec 27, 2004
    Last edited: Dec 27, 2004
Loading...

Share This Page