The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ipcheck - grrrrrr

Discussion in 'General Discussion' started by jez9999, Aug 29, 2005.

  1. jez9999

    jez9999 Well-Known Member

    Joined:
    Jun 10, 2005
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    OK, so I'm regularly receiving these [ipcheck] e-mails, which go something like:

    The thing is, this is just stupid. For one, I do have /etc/hosts setup to resolve my hostname to my machine's IP address. However, I don't have (in this example) blah.com setup on my nameserver software - why would I? My machine's hostname does NOT have to be in a domain the nameserver for which is hosted on my local machine! If ipcheck had bothered to lookup the hostname on the internet it would've found that it resolved to my IP address fine; the hostname is just resolved by one of my VPS provider's nameservers.

    So, my question is, how can I make ipcheck behave more sensibly, or just disable it altogether?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The problem won't be with ipcheck as it does work perfectly correctly in the scenario you have described.

    Is your hostname an FQDN in the format hostname.domain.tld?

    If so, does the authorattitive DNS server for domain.tld have an A record for hostname pointing to your main IP address on the server?

    If that is correct, are you running named on your server?

    If you are, do you have your servers IP address in /etc/resolv.conf?

    If you do, have you checked that there is no zone file for domain.tld configured in the local DNS?

    If there is a zone for domain.tld on the local DNS, delete it.

    Double check your /etc/hosts file ane make sure that the only lines are:

    127.0.0.1 localhost
    11.22.33.44 hostname.domain.tld hostname

    With your servers appropriate values.

    And finally, if your main network interface is not eth0 (e.g. it's eth1 or a VPS using venet0:0 then ensure that you have that set correctly in WHM > Basic cPanel/WHM Setup > Alternate Main Ethernet Device
     

Share This Page