[ipcheck] Problem with DNS setup on server1.sshah.co

ssj4sunny

Registered
Dec 19, 2012
3
0
1
cPanel Access Level
Root Administrator
Hi there! I am having a few problems with my cPanel and WHM. I keep getting this e-mail from the system:

--
IMPORTANT: Do not ignore this email.

Your hostname (server1.sshah.co) could not be resolved to an IP
address. This means that /etc/hosts is not set up correctly, and/or
there is no dns entry for server1.sshah.co. Please be sure that the
contents of /etc/hosts are configured correctly, and also that
there is a correct 'A' entry for the domain in the zone file.

Some or all of these problems can be caused by /etc/resolv.conf
being setup incorrectly. Please check that file if you believe
everything else is correct.

You may be able to automatically correct this problem by using the
'Add an A entry for your hostname' option under 'Dns Functions' in
your Web Host Manager.
--
Whenever I try to access my mail login portal or something similar with server1.sshah.co I get a DNS lookup error. I have tried to add the A entry under WHM but it still does solve the problem.

This is what is in my hosts file in the etc directory:

::1 localhost.localdomain localhost
127.0.0.1 localhost.localdomain localhost
109.111.217.174 server1.sshah.co server1
and resolv.conf:

nameserver 8.8.8.8
nameserver 8.8.4.4
Anyone know a solution for this?

Thanks.
Sunny
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
In WHM you go to -> DNS Functions-> Edit Dns Zone
choose Zone sshah.co,
then add this entry:
server1 14400 IN A 109.111.217.174

and click "Save"
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
In SSH command line, as root, do this:
Code:
/scripts/ipcheck --verbose
what do you get?
 

ssj4sunny

Registered
Dec 19, 2012
3
0
1
cPanel Access Level
Root Administrator
Thanks for the reply once again.

I got this in SSH:

[email protected] [~]# /scripts/ipcheck --verbose
[ipcheck] sent email:

IMPORTANT: Do not ignore this email.

Your hostname (server1.sshah.co) could not be resolved to an IP
address. This means that /etc/hosts is not set up correctly, and/or
there is no dns entry for server1.sshah.co. Please be sure that the
contents of /etc/hosts are configured correctly, and also that
there is a correct 'A' entry for the domain in the zone file.

Some or all of these problems can be caused by /etc/resolv.conf
being setup incorrectly. Please check that file if you believe
everything else is correct.

You may be able to automatically correct this problem by using the
'Add an A entry for your hostname' option under 'Dns Functions' in
your Web Host Manager.

Notification => [email protected]m via EMAIL [level => 2]
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
Name servers of domain sshah.co are:

ns1.farbyte.com IP: 109.111.221.7
ns2.farbyte.com IP: 109.111.217.20

The IP address of domain sshah.co is 109.111.217.174, so I suppose you are running your server in that IP.
Those name servers above do not know hostname server1.sshah.co.

You obviously have a DNS Zone for the domain sshah.co in your server, but because those name servers above do not point to your server it is NOT used.

So you have 2 ways to fix this:

1: set the name servers of the domain sshah.co to point to your server.

2: where the DNS Zone of the domain sshah.co is hosted now, add the A record for the hostname server1.sshah.co.