The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IP's deactivating on reboot - missing from WHM

Discussion in 'General Discussion' started by xghozt, Mar 7, 2010.

  1. xghozt

    xghozt Member

    Joined:
    Oct 15, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    I'm not going to list the IP's here, so I will use nicknames, ip1, ip2, and ip3. And I will explain the situation here, and I hope someone can help us.

    We're trying to setup a new server, but we built it from scratch, which I've never done before. And we're running into some weird problems.

    Here is how things should be setup:

    ip1 = main shared ip
    ip2 = nameserver1
    ip3 = nameserver2

    Software: CentOS 5 with cPanel and WHM

    ---
    Here is how things are setup (on accident):

    ip2 = main shared ip
    ip3 = free ip / nameserver 2
    ip1 = exists but not visible in WHM

    When a new cpanel account is created, it get's assigned ip1.
    When we reboot the server, ip2 and ip3 become inactive.

    All 3 ip's exist in the /etc/hosts file.

    We can access the server from all 3 ip's.

    Attempting to assign an IP address to ip2 and ip3 (the namservers) via WHM, does nothing (loads forever saying "Assigning Ip Address for...")

    Attempting to add ip1 as a free system IP to use as the main shared ip comes up with an error, saying "All Requested Ips were already active".

    ----
    Any help would be appreciated. We want the main ip to be ip1, and not ip2, and I can't figure out why it thinks ip1 is already added. And every time we reboot the server we completely lose connectivity.
     
  2. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Depending on the method you used to bind the additional IPs, they may be taking over for the default eth0 address on boot and causing problems.

    The proper way to have addon IPs with cPanel is to add them through the WHM interface. Bind the main IP to eth0 via the normal method (ifcfg-eth0 for instance) but leave the addons unbound. The Initial Setup Wizard will give you an option to do this but since you are presumably past that point, you'll want to add the IPs in the WHM under Main >> IP Functions >> Add a New IP Address.

    Make sure that before you do this that you remove the existing addon IPs however you've bound them. cPanel uses a custom service called ipaliases that manages the addon IPs and you can restart it (if necessary) with:

    Code:
    /etc/init.d/ipaliases restart
     
  3. xghozt

    xghozt Member

    Joined:
    Oct 15, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Thanks. We figured it out. it was GNOME's Network Manager utility conflicting with cPanel. :eek: We removed GNOME, we don't need it anyway.
     
Loading...
Similar Threads - IP's deactivating reboot
  1. keat63
    Replies:
    7
    Views:
    452
  2. zyrcon
    Replies:
    3
    Views:
    295
  3. tloosle
    Replies:
    13
    Views:
    1,181

Share This Page