The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IPTables

Discussion in 'General Discussion' started by kgordon, Mar 15, 2006.

  1. kgordon

    kgordon Active Member

    Joined:
    Oct 4, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    I was just wondering, does cPanel have anything in it that automatically restarts IPTables every night at around 2AM?

    For whatever reason, everytime I kill iptables it restarts itself at about 2AM. When it does this it automatically blocks ports >1024 even though the iptables-config says to allow.


    Does anyone know if this is part of cPanel?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    This may happen if you have WHM > Tweak Security > SMTP Tweak enabled. That sai,d it would suggest that you have have something configured ion /etc/sysconfig/iptables that you shouldn't have.
     
  3. dct

    dct Member

    Joined:
    Nov 24, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I think you can restart with crontab add this command

    service iptables restart
     
  4. maximus_marcus

    maximus_marcus Well-Known Member

    Joined:
    Mar 9, 2006
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Hello ,

    Check to make sure that you have provided the port in the /etc/apf/conf.apf , if apf happens to be installed on the server . Causing restarting the apf on the server may cause this issue or else you can go ahead and add the following rule

    iptables -A INPUT -p tcp -s 0/0 --dport 1024 -j ACCEPT

    Hope this helps you out!!!

    Regards,
    Marcus
    The New Phase OF Support
     
  5. asish

    asish Active Member

    Joined:
    Dec 4, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    Why do you want to stop iptables permenantly. It is not a good idea to stop the firewall.

    If you insist, you can remove the iptables* from /etc/init.d/rc.d This would servre your purpose.

    try
    service iptables stop
    instead of killing the processes.
     
Loading...

Share This Page