wswd

Well-Known Member
Aug 9, 2005
141
16
168
cPanel Access Level
Root Administrator
IPv6 was actually something we were looking forward to, since we have a healthy amount of Asian clients who can make use of it.

Is there anything special you need to do to get it to work? Any hidden setting somewhere?

IPv6 is working on the server. I can assign an address to an account. ipv6.domain.com is pingable (ping6), traceroutable (traceroute6), and the httpd.conf file has both the IPv4 and the IPv6 addresses, but no website loads at the IPv6 address. IPv4 is no problem. Yes, I have IPv6 on my home ISP and even tried using other sites to verify that it isn't working.

Thought it might be a firewall issue, though that wouldn't make a great deal of sense, so disabled all the firewalls and still no luck.

Any setting somewhere that I might be missing?

Thanks!
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
76
308
cPanel Access Level
Root Administrator
Are you going through a webproxy at all?

Is there anything in the apache, or systems, logs that verifies the web request is making it to your server?
 

wswd

Well-Known Member
Aug 9, 2005
141
16
168
cPanel Access Level
Root Administrator
Thanks Kenneth!

No, no proxy or anything. Nothing weird. Anywhere specific to look? Don't see anything weird in the apache logs or such. Netstat looks like the connection is good.

Anywhere I should specifically be looking?
 

wswd

Well-Known Member
Aug 9, 2005
141
16
168
cPanel Access Level
Root Administrator
In case it helps anyone else, my httpd.conf file had "Listen 0.0.0.0:80". I changed it to "Listen 80" so that all protocols are covered.

That fixed it immediately. Not sure if an Apache rebuild is going to attempt to delete that. We'll have to see, but so far so good.