The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IRCd and Ulimits

Discussion in 'General Discussion' started by demine0, Oct 7, 2003.

Thread Status:
Not open for further replies.
  1. demine0

    demine0 Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    I've had lots of problems with cpanel and ulimits. Im trying to run unreal IRCD 3.2 on my box from a shell. Im having problems b/c of the crapy ulimit cpanel sets up.

    with root:
    root@srv01 [~]# ulimit -u
    14335

    I su to the shell my ircd is on and i do the same.
    digtoxshell@srv01 [~/Unreal3.2]# ulimit -u
    20

    How can i change this to a perminate HIGH number? I created the account using adduser from root.

    I've also tryed ulimit -u 65535 from root
    then suing
    but that doesnt work.

    I get this error when i run the ircd.:
    The OS enforces a limit on max open files
    Hard Limit: 100 MAXCONNECTIONS: 1024
    Fix MAXCONNECTIONS
     
    #1 demine0, Oct 7, 2003
    Last edited: Oct 7, 2003
  2. Chaos_Theory

    Chaos_Theory Registered

    Joined:
    Jun 24, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    well you could goto
    /etc/security/limits.conf
    and manually set the limits

    cPanel.net Support Ticket Number:
     
  3. demine0

    demine0 Well-Known Member

    Joined:
    Mar 25, 2003
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the reply.
    Any idea what i would put in there? What i want to set is not a domin. Its a shell account.

    I also dont see a option for ulimit ot sile dyceptors there.

    cPanel.net Support Ticket Number:
     
  4. Chaos_Theory

    Chaos_Theory Registered

    Joined:
    Jun 24, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    if you read the commented text above it should give you a fairly good idea what to put

    domain can be a username

    ulimit -u shows the max amount of process aloud. thats why root is basically unlimited :P

    cPanel.net Support Ticket Number:
     
  5. danielaugustus

    danielaugustus Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Well, I tried everything on this topic . Nothing did it !

    Whe I change limits.conf I need to do what to it take efect ?


    Cause I need more processes per user , actually 20, and more oepn file , 100 now.

    I need to rise this . But I only can rise under root. I changed the /etc/profile to run a ulimit to rise it .... But simply didnt work.

    The I tried /etc/security/limis.conf ... I changed it .. What needs to be done to work ?

    Well, I need this. But I cant set thsio up ..
     
  6. rodstewart

    rodstewart Active Member

    Joined:
    Feb 4, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamburg Germany
    cPanel Access Level:
    DataCenter Provider
    Do the following,

    go into /etc/profile.d/ and edit the two files limits.csh and limits.sh.

    after that edit the file /etc/profile

    and all should work.

    greets Sven
     
  7. No-State

    No-State Member

    Joined:
    Jun 12, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    This is the FD_SETSIZE fix

    Do the following,

    go into /etc/profile.d/ and edit the two files limits.csh and limits.sh.

    after that edit the file /etc/profile

    This has worked on my system today.

    Thanx Sven
     
  8. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    how did u edited them? i could not get it to work
     
  9. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
Thread Status:
Not open for further replies.

Share This Page