Is Apache 2.4 coming at all?

DjiXas

Well-Known Member
Feb 10, 2007
294
0
166
Been years now, what is your problem, guys?
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
308
cPanel Access Level
Root Administrator
Apache 2.4 is released and supported by cPanel. To use Apache 2.4, your server must meet the following requirements:

1. Running cPanel & WHM 11.36 or newer
2. Using EasyApache 3.18 or newer

More information about Apache 2.4 can be found in the EasyApache 3.18 release notes: EAReleaseNotes318 < EasyApache < TWiki
 

DjiXas

Well-Known Member
Feb 10, 2007
294
0
166
^

So you are suggesting running unstable cPanel buibld, thanks but no thanks
 

cPLaurenceS

cPanel Staff - Technical Writer II
Staff member
Oct 30, 2012
41
4
83
Houston, TX
cPanel Access Level
Root Administrator
Twitter
Apache 2.4.4 is released. It is a security and bug fix release. Here is changelog http://www.apache.org/dist/httpd/CHANGES_2.4.4

It might take some hours to sync to all mirrors. :D
Hi Ari,

We're working on getting Apache 2.4 upgraded to 2.4.4, it will be available soon.

Be sure to keep an eye on the magical EasyApache Change Log for updates:
EasyApache < AllDocumentation/ChangeLog < TWiki

FYI, the cPanel EasyApache Team was out at ApacheCon NA in Portland last week, and there were quite a few useful sessions there that covered 2.4 and 2.4.4 features:

Apache HTTP Server 2.4 Problem Diagnosis - ApacheCon NA 2013 | Presentation: Apache HTTP Server 2.4 Problem Diagnosis
Access control in Apache httpd 2.4 - ApacheCon NA 2013 | Presentation: Access control in Apache httpd 2.4
What's new in httpd 2.4 - ApacheCon NA 2013 | Presentation: What's new in httpd 2.4

I'm not sure if these will be made public, but if you can watch them, they're well worth the time.

Thanks,
-ls

Laurence Simon
Technical Writer (EasyApache Team)
cPanel, Inc.