Is it safe to remove Perl from yum excludes?

4u123

Well-Known Member
PartnerNOC
Jan 2, 2006
897
18
168
We have encountered an issue with latest updates on our CL6 servers in that a conflict has arisen with perl-git as a result of perl being in the excludes section of yum.conf. We added this in on the recommendation of cpanel as I understand the perl installation is maintained by cpanel on these servers and not by the OS.

Code:
Error: Package: perl-Git-1.7.1-9.el6_9.noarch (@cloudlinux-x86_64-server-6)
           Requires: git = 1.7.1-9.el6_9
           Removing: git-1.7.1-9.el6_9.x86_64 (@cloudlinux-x86_64-server-6)
               git = 1.7.1-9.el6_9
           Updated By: git-1.7.1-10.el6_10.x86_64
(cloudlinux-x86_64-server-6)
               git = 1.7.1-10.el6_10
           Available: git-1.7.1-2.el6.1.x86_64 (cloudlinux-x86_64-server-6)
               git = 1.7.1-2.el6.1
           Available: git-1.7.1-3.el6_4.1.x86_64
(cloudlinux-x86_64-server-6)
               git = 1.7.1-3.el6_4.1
           Available: git-1.7.1-4.el6_7.1.x86_64
(cloudlinux-x86_64-server-6)
               git = 1.7.1-4.el6_7.1
           Available: git-1.7.1-8.el6.x86_64 (cloudlinux-x86_64-server-6)
               git = 1.7.1-8.el6
Error: Package: git-1.7.1-10.el6_10.x86_64 (cloudlinux-x86_64-server-6)
           Requires: perl-Git = 1.7.1-10.el6_10
           Installed: perl-Git-1.7.1-9.el6_9.noarch
(@cloudlinux-x86_64-server-6)
               perl-Git = 1.7.1-9.el6_9
 
  • Like
Reactions: imorandin