The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is my SPF set up correctly?

Discussion in 'E-mail Discussions' started by CeceXX, Sep 28, 2015.

  1. CeceXX

    CeceXX Registered

    Sep 28, 2015
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Website Owner
    My email accounts are working properly and my (shared) server IP doesn’t seem to be blacklisted. When sending emails, I do not get any bounce messages. The emails I send all look fine and their content is plain text. They don’t contain any trigger words such as “test”.

    Though, it seems like Google Gmail servers have been flagging my emails as “Junk” for a very long time but other providers, such as Yahoo Mail, don’t. Creating more email accounts didn’t help. I have also used email accounts that belonged to different domains.

    So I would like to make sure my SPF is setup correctly. My SPF looks like this:
    Name: (please notice the ending dot)
    TTL: 14400
    Class: IN
    Type: TXT
    Record: v=spf1 +a +mx ~all

    The fact is that the IP looks slightly different from the one given from my hosting provider.

    Is my SPF set up correctly? Thanks!
  2. Jcats

    Jcats Well-Known Member

    May 25, 2011
    Likes Received:
    Trophy Points:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    We wouldn't be able to tell you without knowing the IP of the mail server, and if that matches the IP you show in the record, what you can do is go to:
    send a test email to the email shown on the screen, then refresh, it will tell you if your SPF/DKIM/rDNS etc are setup correctly.

Share This Page