The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is possible have diferent PHP and MySQL versions in the same WHM instalation

Discussion in 'General Discussion' started by Andrés GL, Mar 25, 2015.

  1. Andrés GL

    Andrés GL Registered

    Joined:
    Mar 25, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Praha
    cPanel Access Level:
    Root Administrator
    Hello,

    I have a VPS with WHM 11.44.1 (build 23) and is administrated for an external company. The WHM is running on Centos with 24 processors and 16GM of RAM. I have several cPanels where I develop my different projects. (It's like a reseller but only for me, I don't sell hosting).

    The problem I have is that I need a special version of MySQL and PHP. I contacted with the company to have the option to change only in the cPanel of this project the PHP and MySQL version but they told me that it's not possible. They told me that the server have to have only one version of PHP and MySQL... I think it's not true because I had several servers with cPanel and another server with WHM access and I could change the version.

    So for that I'm here asking you if it's possible or not.

    Thank you so much and I hope you can help me.

    :)
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Normally you would use EasyApache to change the PHP version used by Apache. Without third party solutions, or other custom changes, it is not possible right now to have multiple versions of PHP installed on a single server. You can track the following feature request to keep abreast of our development on this feature: http://features.cpanel.net/responses/allow-to-install-multiple-php-5x-versions

    MySQL can be upgraded using the MySQL Upgrade Wizard in WHM. On 11.44 you should be able to upgrade to either MySQL 5.5 or MySQL 5.6. It is only possible to have one version of MySQL installed on a cPanel & WHM server.

    Both actions require root privileges on the server.

    Also, please consider upgrading to cPanel & WHM version 11.48. The version you are currently running will reach end of life in June.

    Please let me know whether the above information answered your questions.
     
  3. Andrés GL

    Andrés GL Registered

    Joined:
    Mar 25, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Praha
    cPanel Access Level:
    Root Administrator
    @cPanelKenneth,

    Thank you so much for your answers and advice. It was helpful.
     
Loading...

Share This Page