Is self-signed SSL not compatible with mailclients?

JessC

Member
Oct 3, 2019
12
2
3
Philippines
cPanel Access Level
Reseller Owner
Hi experts,

We recently acquired a cPanel hosting from GoDaddy.
I'm currently testing the emails and sending and receiving through the Webmail.

The problem is when I tried adding the account in the thunderbird mailclient.

2020-02-19 08:38:54 mail.setup INFO Initializing setup wizard
2020-02-19 08:38:54 mail.setup INFO Email account setup dialog loaded.
2020-02-19 08:38:54 mail.setup INFO switching to UI mode start
2020-02-19 08:39:15 mail.setup INFO findConfig()
2020-02-19 08:39:15 mail.setup INFO switching to UI mode find-config
2020-02-19 08:39:15 mail.setup INFO Requesting <http://autoconfig.domain.com.ph/mail/config-v1.1.xml>
2020-02-19 08:39:15 mail.setup INFO Requesting <http://domain.com.ph/.well-known/autoconfig/mail/config-v1.1.xml>
2020-02-19 08:39:15 mail.setup INFO Requesting <https://live.thunderbird.net/autoconfig/v1.1/domain.com.ph>
2020-02-19 08:39:15 mail.setup INFO Requesting <https://live.thunderbird.net/dns/mx/domain.com.ph>
2020-02-19 08:39:15 mail.setup INFO Requesting <https://autodiscover.domain.com.ph/autodiscover/autodiscover.xml>
2020-02-19 08:39:15 mail.setup INFO Requesting <https://domain.com.ph/autodiscover/autodiscover.xml>
2020-02-19 08:39:15 mail.setup INFO Requesting <http://autodiscover.domain.com.ph/autodiscover/autodiscover.xml>
2020-02-19 08:39:15 mail.setup INFO call 0 took 14ms and failed with local file not found
2020-02-19 08:39:15 mail.setup INFO call 0 took 31ms and failed with 0 unknown error, probably no host connection at <http://autoconfig.domain.com.ph/mail/config-v1.1.xml>
2020-02-19 08:39:15 mail.setup INFO call 0 took 31ms and failed with 0 unknown error, probably no host connection at <https://autodiscover.domain.com.ph/autodiscover/autodiscover.xml>
2020-02-19 08:39:15 mail.setup INFO call 2 took 30ms and failed with 0 unknown error, probably no host connection at <http://autodiscover.domain.com.ph/autodiscover/autodiscover.xml>
2020-02-19 08:39:15 mail.setup INFO call 3 took 392ms and failed with 404 Not Found
2020-02-19 08:39:16 mail.setup INFO call 2 took 689ms and failed with 404 Not Found at <https://live.thunderbird.net/autoconfig/v1.1/domain.com.ph>
2020-02-19 08:39:16 mail.setup INFO call 1 took 1178ms and failed with 0 unknown error, probably no host connection at <https://domain.com.ph/autodiscover/autodiscover.xml>
2020-02-19 08:39:16 mail.setup INFO call 4 took 1180ms and failed with 0 unknown error, probably no host connection
2020-02-19 08:39:18 mail.setup INFO call 1 took 3308ms and failed with 404 Not Found at <http://domain.com.ph/.well-known/autoconfig/mail/config-v1.1.xml>
2020-02-19 08:39:18 mail.setup INFO call 1 took 3309ms and failed with 0 unknown error, probably no host connection
2020-02-19 08:39:18 mail.setup WARN spinner start looking_up_settings_guess
2020-02-19 08:39:18 mail.setup INFO status msg: Looking up configuration: Trying common server names
2020-02-19 08:39:18 mail.setup INFO progress callback host imap.domain.com.ph port 143 type imap
2020-02-19 08:39:18 mail.setup INFO progress callback host smtp.domain.com.ph port 587 type smtp
2020-02-19 08:39:18 mail.setup INFO progress callback host imap.domain.com.ph port 143 type imap
2020-02-19 08:39:18 mail.setup INFO progress callback host pop3.domain.com.ph port 110 type pop3
2020-02-19 08:39:18 mail.setup INFO progress callback host imap.domain.com.ph port 143 type imap
2020-02-19 08:39:18 mail.setup INFO progress callback host pop.domain.com.ph port 110 type pop3
2020-02-19 08:39:18 mail.setup INFO progress callback host pop3.domain.com.ph port 110 type pop3
2020-02-19 08:39:18 mail.setup INFO progress callback host pop.domain.com.ph port 110 type pop3
2020-02-19 08:39:18 mail.setup INFO progress callback host smtp.domain.com.ph port 587 type smtp
2020-02-19 08:39:18 mail.setup INFO progress callback host smtp.domain.com.ph port 25 type smtp
2020-02-19 08:39:18 mail.setup INFO progress callback host smtp.domain.com.ph port 587 type smtp
2020-02-19 08:39:18 mail.setup INFO progress callback host smtp.domain.com.ph port 25 type smtp
2020-02-19 08:39:19 mail.setup INFO progress callback host mail.domain.com.ph port 143 type imap
2020-02-19 08:39:19 mail.setup INFO progress callback host mail.domain.com.ph port 110 type pop3
2020-02-19 08:39:19 mail.setup INFO progress callback host domain.com.ph port 143 type imap
2020-02-19 08:39:19 mail.setup INFO CHOOSING imap mail.domain.com.ph:143, auth method 3, SSL 3
2020-02-19 08:39:19 mail.setup INFO CHOOSING pop3 mail.domain.com.ph:110, auth method 3, SSL 3
2020-02-19 08:39:19 mail.setup INFO progress callback host mail.domain.com.ph port 143 type imap
2020-02-19 08:39:30 mail.setup INFO guessConfig failed: Can't find a server
2020-02-19 08:39:30 mail.setup WARN status error failed_to_find_settings
2020-02-19 08:39:30 mail.setup INFO status msg: Thunderbird failed to find the settings for your email account.
2020-02-19 08:39:30 mail.setup INFO manual edit
2020-02-19 08:39:30 mail.setup WARN ReferenceError: kDebug is not defined
2020-02-19 08:39:30 mail.setup INFO switching to UI mode manual-edit-have-hostname
2020-02-19 08:39:30 mail.setup WARN ReferenceError: kDebug is not defined

 
Last edited by a moderator:

martin MHC

Well-Known Member
Sep 14, 2016
212
34
28
UK
cPanel Access Level
Root Administrator
I always manually set up mail clients. Are you using the details as provided on the CPanel Email's set up page?

Port 143 does not appear to be a standard. My default Email ports are 465 (SMTP) and 993 (IMAP) -- you should manually try these maybe.

Self signed certificates will never auto-register with Thunderbird or any other 3rd party client because they are, er, self signed, so there's no actual Trust. I have found Thunderbird to be one of the easiest mail clients to set up with CPanel emails.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,261
313
Houston
Hello,


1. it looks like you're trying to use AutoConfigure but may not have it set up. Information on this can be found here: AutoConfig and Autodiscover | cPanel & WHM Documentation

2. The inbound/outbound mailserver should be mail.domain.tld for both not pop/smtp - unless you have explicitly set up pop.domain.tld and smtp.domain.tld

3. As @martin MHC noted the autoconfiguration script is super handy and the details provided on the email setup page tell you exactly what to enter in.

Thanks!