Is there a way to force ImageMagick 4.2.9 and GDLib 1.8.x ?

mpierre

Well-Known Member
Jun 30, 2002
196
0
166
I have a new server.

If I install GDLib and Image-Magick using EasyApache(for GDLib) and the Install RPM in WHM(for IM ) I get versions 2+ for GDLib and 5.4+ for IM.

I need versions 4.2.9 for IM and 1.8.x for GDLib.

I know I could always uninstall the IM RPM and install manually the 4.2.9 package.

However, won't the next CPanel upgrade replace it ?

Same thing for GDLib ???

Ironically, 1.8.4 was present when I installed the server initially, but we had problems with another module somehow GDLib got upgraded...

As anyone got an idea on how to install these version AND KEEP THEM ???
 

mpierre

Well-Known Member
Jun 30, 2002
196
0
166
Never mind...

I have managed to find workarounds for all the problems.

For example, I discovered that the MASK flag of IM5 is the reverse of the value of IM4...