The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is there an easy way to allow customers to choose PHP version?

Discussion in 'General Discussion' started by electric, Dec 18, 2012.

  1. electric

    electric Well-Known Member

    Joined:
    Nov 5, 2001
    Messages:
    697
    Likes Received:
    1
    Trophy Points:
    18
    Hello,

    We're still using PHP 5.2.x on our shared servers, since there are still so many people who have incompatible scripts with PHP 5.3 or higher.

    However, we have more and more customers who are asking for PHP 5.3 and PHP 5.4.

    I know CloudLinux has the "PHP Selector" utility, but we do not want to use cloudlinux for these servers.

    I have seen some web hosts who have a "choose PHP version" icon in their cpanel, and I am wondering how they do that. As far as I can see, this is not a built-in utility in cpanel. Is it a plugin?

    Otherwise.. what is the best (easiest) way to set things up so customers can easily select their desired PHP version?

    Thanks!
     
  2. electric

    electric Well-Known Member

    Joined:
    Nov 5, 2001
    Messages:
    697
    Likes Received:
    1
    Trophy Points:
    18
    Anyone have any ideas?
     
  3. hgrg

    hgrg Well-Known Member

    Joined:
    Oct 4, 2010
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    i guess they use a cgi wrapper and they change the php handler for the user via a custom script
     
  4. PlotHost

    PlotHost Well-Known Member

    Joined:
    Apr 29, 2011
    Messages:
    253
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Twitter:
Loading...

Share This Page