bsasninja

Well-Known Member
Sep 2, 2004
527
0
166
I´m getting this text at /var/log/messages several times

server1 kernel: post_create: setxattr failed, rc=122 (dev=sda8 ino=6024757)

I tried a serch on google but I didnt find anything. Any clues and posible solution?

Thanks!!
 

HostMerit

Well-Known Member
Oct 24, 2004
164
0
166
New Jersey, USA
cPanel Access Level
DataCenter Provider
This is due to SELinux. I've had the same issues with CentOS 4.3 on my new servers.

See examples on Google

Regardless, edit /etc/sysconfig/selinux and set

SELINUX=disabled


Restart the server and there should be no more issues. Too many problems with SELinux, just disable it.
 

adept2003

Well-Known Member
Aug 11, 2003
283
0
166
~ "/(extra|special)/data"
We've just had a similar problem with one of our servers... it turns out that "rc=122" is an error code indicating a quota problem.

Sure enough, there was an account over its quota: "WHM -> Account Information -> Show Accounts over Quota". We fixed the issue by increasing the user's quota & freeing up some disk space. No more error messages in the log & no need to disable SELinux :)

I hope this solution helps (& is worth having dug up an relatively old thread!)
 

katmai

Well-Known Member
Mar 13, 2006
564
3
168
Brno, Czech Republic
it is a known fact that selinux must be disabled on cpanel servers. first of all it breaks postgresql databases, second gets a ton of errors in the cpanel, and third of all, does not provide the real security that a webserver should have.

i am using grsecurity, and for all i know and all the people out there who are using it, they know as well that this is the thing.

grsec simply rocks.
 

katmai

Well-Known Member
Mar 13, 2006
564
3
168
Brno, Czech Republic
it's not enabled by cpanel, it is enabled when you install the operating system, or the tech that does the installation.