Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Issue saving EXIM configuration

Discussion in 'E-mail Discussion' started by dclaar, Mar 2, 2018.

Tags:
  1. dclaar

    dclaar Registered

    Joined:
    Mar 2, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    It doesn't appear to be possible to create a global exim filter, only a .yaml one; otherwise I might be able to shift the filtering up to the account level. Re-entering 250K lines of exim filters into the cpanel GUI for account filtering...<shudder>

    I thought that the dovecot log files might help, but they want some global config file that either exists someplace else, or that I can't access. And they seem to be binary.

    Sorry for the length, but I'm trying to be complete.
    First, I'm a lowly user. I have had a ticket with lunarpages for a bit (4427801), and they've reached out to cpanel as well (Cpanel support 9309767).

    I have a really large set of exim filters (250K lines), which used to work fine. When they updated to centos 7 and a newer cpanel, the exim save command within the filters stopped working.

    Each user has a simple redirect to the account email. The account email then uses etc/filter to deliver things appropriately, e.g. for user dog:
    Code:
    if $h_to matches "dog" then
      save $home/mail/domain/dog/
      seen finish
    endif
    Previously, this would create a message in $home/mail/domain/dog/new. Now, even though "Track Delivery" happily reports success:
    Code:
    Delivered To: /home/domain_account/mail/domain/dog/
    Router: central_user_filter
    Transport: address_directory
    
    There's no email.

    Support suggested changing to
    Code:
    if $h_to matches "dog" then
      deliver dog@example.com
      seen finish
    endif
    That also doesn't work.

    I know that it is hitting the exim filter, because I have logwrite messages, and because I have added a deliver dog@example.com line, and the email shows up there.


    As the system is now centos, the redhat-release bit doesn't work, and there's no centos-release, but here's the suggested status command.

    Code:
    $ grep '' /etc/redhat-release /usr/local/cpanel/version /var/cpanel/envtype ; grep CPANEL= /etc/cpupdate.conf
    grep: /etc/redhat-release: No such file or directory
    /usr/local/cpanel/version:11.68.0.27
    /var/cpanel/envtype:hyper-v
    grep: /etc/cpupdate.conf: No such file or directory
    
     
    #1 dclaar, Mar 2, 2018
    Last edited by a moderator: Mar 4, 2018
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,214
    Likes Received:
    1,937
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Per the support ticket (9309767), it looks like part of the issue was that a custom "filter" file was setup for the default account (e.g. $cpusername@domain.tld) as opposed to globally via the "Global Email Filters" option in cPanel. Additionally, the ability to customize the filter via the UI is limited to some extent. We have a feature request open at the following URL to enhance this:

    Enhance Email Filtering Options

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice