The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with caldav sync DoS Protection Activated

Discussion in 'General Discussion' started by kerridge, Mar 21, 2017.

  1. kerridge

    kerridge Registered

    Joined:
    Jul 27, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    Hi I am encountering an issue when synchronising my calendar with caldav. It's quite a big calendar, synchronising with Outlook using caldav synchroniser.

    Anyway, the sync causes the following error:-

    DoS Protection Activated; PROPFIND larger than 100k discarded

    I have googled and can't find this anywhere on the internet, so can't use caldav any more.

    Could it be some kind of attachment on a calendar item causing a size limit to be exceeded? I vaguely recall dragging an email to the calendar to create a calendar entry..

    If anyone could cast any light at all on this it would be very useful.

    Kerry

    The error is found in the file: /usr/local/cpanel/logs/cpdavd_error_log
     
    #1 kerridge, Mar 21, 2017
    Last edited by a moderator: Mar 21, 2017
  2. kerridge

    kerridge Registered

    Joined:
    Jul 27, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    I have found where the error text can be found:

    Code:
    /usr/local/cpanel/Cpanel/Httpd.pm:
            if ( int $httphead->header('content-length') > 100000 ) {
                print STDERR "DoS Protection Activated; PROPFIND larger than 100k discarded\n";
                $self->force_last_request();
            }
    Here are my server details (root access)
    Code:
    /etc/redhat-release:CentOS release 5.11 (Final)
    /usr/local/cpanel/version:11.56.0.43
    /var/cpanel/envtype:xen pv
    CPANEL=11.56
    Server version: Apache/2.2.31 (Unix)
    Server built:   Oct 28 2016 14:05:39
    Cpanel::Easy::Apache v3.34.7 rev9999
    PHP 5.6.27 (cli) (built: Oct 28 2016 14:13:36)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
        with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.1.1, Copyright (c) 2002-2016, by ionCube Ltd.
        with Zend Guard Loader v3.3, Copyright (c) 1998-2014, by Zend Technologies
    mysql  Ver 14.14 Distrib 5.6.33, for Linux (x86_64) using  EditLine wrapper
     
  3. kerridge

    kerridge Registered

    Joined:
    Jul 27, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    I've changed /usr/local/cpanel/Cpanel/Httpd.pm:

    Code:
            #if ( int $httphead->header('content-length') > 100000 ) {
            #    print STDERR "DoS Protection Activated; PROPFIND larger than 100k discarded\n";
            #    $self->force_last_request();
            #}
            #elsif ( int $httphead->header('content-length') > 0 ) {
            if ( int $httphead->header('content-length') > 0 ) {
    It now works.

    Is there any way of resolving this more elegantly?
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,618
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please feel free to open a ticket directly to cPanel Technical Support about this. I would think if this is an issue not many come across but you have due to the large calendar, they'd like to know about it to make the cPanel product better.
     
    kerridge likes this.
  5. kerridge

    kerridge Registered

    Joined:
    Jul 27, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    Cpanel concurred and advised that I create a feature request, I have now located here They also advised I could use the standardised hook system to make the change more permanent.
     
Loading...

Share This Page