The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with MX Record Displaying incorrectly

Discussion in 'E-mail Discussions' started by tylerjr92, May 21, 2016.

  1. tylerjr92

    tylerjr92 Member

    Joined:
    May 24, 2014
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Reseller Owner
    So I have a wildcard SSL Cert.
    I have installed this cert in my VPS WHM>>Service Configuration>>Manage Service SSL Certificates.
    I have enabled Mail SNI.
    My MX Records for this domain are as follows:
    0 MX mail.example.com
    10 MX example.com

    The issue I am having is when my clients goto cPanel Home>>Email Accounts>>Setup Mail Client the incorrect settings are being displayed for the incoming and outgoing servers.

    They see my servers FQDN Hostname mydesign.example.com and not mail.example.com

    So far the only workaround I have found is to add my MX records to EACH domain. This is time consuming and not a realistic fix. Has anyone run into this or figured out how to edit these settings? I did see that there was a feature request that was implemented in Version 56 to do this, but I can not find where to edit this information.

    WHM/cPanel version 56.0 (build 20)
     
    #1 tylerjr92, May 21, 2016
    Last edited by a moderator: May 21, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    As I understand, you have a wildcard certificate installed for your services as:

    Code:
    *.example.com
    In order to use the "Mail SNI" functionality with this certificate, you should install the wildcard SSL certificate as "mail.example.com" via cPanel to ensure it's utilized in the email client configuration page. Please also review the following thread:

    Mail SNI mail.<domain> - doesn't work

    Thank you.
     
Loading...

Share This Page