The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

issue with my dns

Discussion in 'Bind / DNS / Nameserver Issues' started by seizart, Oct 2, 2014.

  1. seizart

    seizart Active Member

    Joined:
    Feb 21, 2013
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    hello

    email from my website are allways going into gmail spam and maybe others aswell

    i don t know what to do, it shows clearly that it is sent <<via myserver.com≥≥

    here is my emails source:

    Received: by 10.229.240.198 with SMTP id lb6csp539005qcb;
    Wed, 1 Oct 2014 12:59:43 -0700 (PDT)
    X-Received: by 10.140.95.97 with SMTP id h88mr23954888qge.103.1412193583188;
    Wed, 01 Oct 2014 12:59:43 -0700 (PDT)
    Return-Path: <jeudipm@serveur.myserver.com>
    Received: from serveur.myserver.com (ns506425.ip-167-114-0.net. [167.114.0.xxx])
    by mx.google.com with ESMTPS id w8si2575175qcl.45.2014.10.01.12.59.43
    for <seizart@gmail.com>
    (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
    Wed, 01 Oct 2014 12:59:43 -0700 (PDT)
    Received-SPF: pass (google.com: domain of jeudipm@serveur.myserver.com designates 167.114.0.xxx as permitted sender) client-ip=167.114.0.xxx;
    Authentication-Results: mx.google.com;
    spf=pass (google.com: domain of jeudipm@serveur.myserver.com designates 167.114.0.xxx as permitted sender) smtp.mail=jeudipm@serveur.myserver.com
    Received: from jeudipm by serveur.myserver.com with local (Exim 4.82)
    (envelope-from <jeudipm@serveur.myserver.com>)
    id 1XZQ3s-0005Th-Rg
    for seizart@gmail.com; Wed, 01 Oct 2014 15:59:44 -0400
    To: seizart@gmail.com
    Subject: Overnight Parking Permission
    X-PHP-Script: email.org/wp-admin/admin-ajax.php for 24.201.15.110
    Date: Wed, 1 Oct 2014 15:59:44 -0400
    From: City of email | Overnight Parking Registration <parking@email.org>
    Message-ID: <c42dbac844530225781328da66fec61f@email.org>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
    MIME-Version: 1.0
    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: 8bit
    X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
    X-AntiAbuse: Primary Hostname - serveur.myserver.com
    X-AntiAbuse: Original Domain - gmail.com
    X-AntiAbuse: Originator/Caller UID/GID - [503 503] / [47 12]
    X-AntiAbuse: Sender Address Domain - serveur.myserver.com
    X-Get-Message-Sender-Via: serveur.myserver.com: authenticated_id: jeudipm/from_h
     
  2. seizart

    seizart Active Member

    Joined:
    Feb 21, 2013
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    one thing i need to add is emails are not hosted on my server but in another server, it probably add to the complexity
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please see Google's bulk sender policy for a better idea of how they determine what mail is labeled SPAM:

    https://support.google.com/mail/answer/81126

    Thank you.
     
  4. seizart

    seizart Active Member

    Joined:
    Feb 21, 2013
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    i already put a dkim and spf entry, gmail say it passed !

    So i don t see the problem now...

    How can i send the email as name@mydomain.org and not user@myserverdomain.org, i think that might be the problem, because the user who sent the email (with wordpress) is in fact different from the email adress)
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The default behavior when sending email through PHP is to use the cPanel username and hostname of the server to construct the envelope-sender address. If you can configure the mailer to use SMTP and authenticate with SMTP AUTH, this will set the correct "Return-Path" in the headers. The other option is to make sure that the application is using the 5th argument to the PHP mail() function to send the '-f' switch to sendmail so that it sets the correct "Return-Path". Keep in mind that your results may vary depending on which mail server is accepting the email.

    Thank you.
     
Loading...

Share This Page