Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Issue with PHP-FPM

Discussion in 'EasyApache' started by earthrat, Mar 27, 2018.

Tags:
  1. earthrat

    earthrat Active Member

    Joined:
    Nov 8, 2010
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Bend, OR
    cPanel Access Level:
    Root Administrator
    Been having this weird issue with PHP-FPM that my data center setup for me awhile back. It has been running fine up until a week ago and now it goes into these fits where instead of opening a website it pops up with a download. The file being downloaded is called download but it is empty with no extension. When I go into WHM and restart PHP-FPM it resolves and the sites load. What makes it even more strange is it only affects Joomla websites and does not affect WordPress or basic HTML sites. Joomla support has no clue or can offer any solutions. Has anyone else experienced this or have an idea why it is doing this?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,791
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you notice any specific output to /usr/local/apache/logs/error_log or the account's PHP-FPM log in the /home/$username/logs/ directory when you notice this behavior?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. earthrat

    earthrat Active Member

    Joined:
    Nov 8, 2010
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    56
    Location:
    Bend, OR
    cPanel Access Level:
    Root Administrator
    In the error_log I get a ton of logs like this:

    Code:
    [Tue Mar 27 14:38:43.442852 2018] [proxy:error] [pid 978486:tid 139879291729664] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/cpanel/ea-php70/root/usr/var/run/php-fpm/6014cfdab3aa221b7f9364474e57ce85dd501edd.sock (*) failed
    [Tue Mar 27 14:38:43.442860 2018] [proxy_fcgi:error] [pid 978486:tid 139879291729664] [client 72.197.51.237:55529] AH01079: failed to make connection to backend: httpd-UDS
    In the ssl_log this is the last few lines in the user logs:

    Code:
    5.9.38.90 - - [27/Mar/2018:06:52:15 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:52:52 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    87.236.20.123 - - [27/Mar/2018:06:53:26 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:54:07 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    61.12.91.106 - - [27/Mar/2018:06:54:50 -0500] "GET /images/blog-images/360-solution.png HTTP/1.1" 200 61237 "https://www.google.co.in/" "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36"
    54.36.148.18 - - [27/Mar/2018:06:55:19 -0500] "GET /portfolio/web-design/ HTTP/1.1" 301 253 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
    194.187.170.141 - - [27/Mar/2018:06:55:56 -0500] "GET /good-design HTTP/1.0" 200 8080 "-" "Mozilla/5.0 (compatible; Qwantify/2.4w; +https://www.qwant.com/)/2.4w"
    85.97.95.91 - - [27/Mar/2018:06:56:04 -0500] "GET /wp-login.php HTTP/1.1" 200 41661 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.97.95.91 - - [27/Mar/2018:06:56:06 -0500] "GET / HTTP/1.1" 200 41661 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    5.9.38.90 - - [27/Mar/2018:06:56:31 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:56:38 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    212.224.76.101 - - [27/Mar/2018:06:56:56 -0500] "GET / HTTP/1.1" 200 41661 "-" "Mozilla/5.0 (compatible; Uptime/1.0; http://uptime.com)"
    5.9.38.90 - - [27/Mar/2018:06:57:10 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:57:26 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:58:06 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:58:22 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:59:14 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:06:59:40 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:00:18 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:01:22 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:02:21 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    128.8.249.140 - - [27/Mar/2018:07:03:02 -0500] "GET /images/articles/Attention.png HTTP/1.1" 200 76948 "https://uhr.umd.edu/info-services/i9-and-e-verify-system/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0"
    5.9.38.90 - - [27/Mar/2018:07:03:16 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:03:29 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:03:29 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:04:59 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:06:07 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:07:37 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:08:08 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:08:33 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:09:22 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    5.9.38.90 - - [27/Mar/2018:07:09:30 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    85.241.101.39 - - [27/Mar/2018:07:10:00 -0500] "GET /wp-login.php HTTP/1.1" 200 41661 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.241.101.39 - - [27/Mar/2018:07:10:01 -0500] "GET / HTTP/1.1" 200 41661 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    5.9.38.90 - - [27/Mar/2018:07:10:42 -0500] "GET /images/articles/Attention.png HTTP/1.0" 200 76948 "-" "-"
    And in the normal website log in the same directory this is some that is just being repeated:

    Code:
    212.224.76.101 - - [27/Mar/2018:06:41:56 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (compatible; Uptime/1.0; http://uptime.com)"
    96.23.122.167 - - [27/Mar/2018:06:46:05 -0500] "GET /wp-login.php HTTP/1.1" 301 244 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    96.23.122.167 - - [27/Mar/2018:06:46:06 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    103.77.213.5 - - [27/Mar/2018:06:49:27 -0500] "GET /wp-login.php HTTP/1.1" 301 244 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    103.77.213.5 - - [27/Mar/2018:06:49:30 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.241.101.39 - - [27/Mar/2018:06:50:46 -0500] "GET /wp-login.php HTTP/1.1" 301 244 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.241.101.39 - - [27/Mar/2018:06:50:48 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.97.95.91 - - [27/Mar/2018:06:56:04 -0500] "GET /wp-login.php HTTP/1.1" 301 244 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.97.95.91 - - [27/Mar/2018:06:56:06 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    212.224.76.101 - - [27/Mar/2018:06:56:56 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (compatible; Uptime/1.0; http://uptime.com)"
    85.241.101.39 - - [27/Mar/2018:07:10:00 -0500] "GET /wp-login.php HTTP/1.1" 301 244 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
    85.241.101.39 - - [27/Mar/2018:07:10:01 -0500] "GET / HTTP/1.1" 301 232 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.1"
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,791
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice