The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with SMTP Server (Exim) Receiving Mail, 550 Administrative Prohibition

Discussion in 'E-mail Discussions' started by apsarah, Sep 19, 2015.

  1. apsarah

    apsarah Registered

    Joined:
    Sep 19, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Perth
    cPanel Access Level:
    Root Administrator
    I'm currently experiencing issues with inbound mail not getting passed the EHLO / HELO step during an inbound SMTP transaction.

    I have tried toggling the "Require HELO before MAIL" option on and off (Service Configuration>Exim Configuration Manager>All), as well as restarting the service, rebooting the server, and rebuilding exim, but unfortunately none of these worked.

    Please see the below SMTP output (Port 25 of below hostname)

    Code:
    220-eha.domain.com ESMTP Exim 4.85 #2 Sat, 19 Sep 2015 03:06:56 -0500
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    HELO google.com
    550 Administrative prohibition
    quit
    221 eha.domain.com closing connection
    
    
    Has anyone experienced this before? What did you do to fix this?
     
    #1 apsarah, Sep 19, 2015
    Last edited by a moderator: Sep 19, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you have any custom options enabled in the /etc/exim.conf.local file on this system? Does this happen when using HELO names other than google.com?

    Thank you.
     
  3. apsarah

    apsarah Registered

    Joined:
    Sep 19, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Perth
    cPanel Access Level:
    Root Administrator
    Hi, I haven't enabled any custom options for exim, and yes it happens for other HELO values.
     
  4. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    275
    Likes Received:
    31
    Trophy Points:
    28
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Can you see if anything helpful shows if you
    Code:
    # tail -f /var/log/maillog /var/log/exim_mainlog
    while sending a test email
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can search for one of the email addresses that's failing to proceed past the HELO check in the Exim logs with commands such as:

    Code:
    exigrep user@domain /var/log/exim_mainlog
    exigrep user@domain /var/log/exim_rejectlog
    Do you notice any particular output that helps clarify the reason for the rejection?

    Thank you.
     
  6. apsarah

    apsarah Registered

    Joined:
    Sep 19, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Perth
    cPanel Access Level:
    Root Administrator
    Thanks for everyone's help, I reviewed the exim settings and found a HELO reject subroutine which was anticipated to prevent connections at HELO from a specific host. It appeared to be causing the issue, as after removing the aforementioned subroutine, the SMTP system returned to normal.

    Thanks again everyone.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page