The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with UCC SSL

Discussion in 'Security' started by Jaspud, Apr 17, 2014.

  1. Jaspud

    Jaspud Registered

    Joined:
    Apr 17, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Have UCC SSL set up on website with SAN domains...The main site the cert is set up on is working great but anytime anyone tries to access an SSL page on one of the other domains, it takes them to the corresponding same page on the main site URL.

    What could I have missed?

    Thanks in advance for any help :)
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    You would need to set it up similar to a wildcard SSL. Since cPanel now supports SNI, just install the same SSL separately for each website you want covered. Or did you already do this?
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Yes, it sounds like you only installed the certificate on one domain name. Please ensure you install the certificate on every domain name that you want it to apply to. Otherwise, the other domain names on that shared IP address will load the content of the default certificate.

    Thank you.
     
  4. Mangoose

    Mangoose Member

    Joined:
    Aug 5, 2014
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello Vanessa, sorry I in more less the same boat as Jaspud.

    Are you and cPanelMichael claiming that out of the box WHM/cpanel allows the installation of the box ? I ask this because at the moment I have dedicated server with SolusVM as the HyperVisor on top of the CentOS 6 - 64 bit OS and two VPS boxes with WHM - cpanel on them.

    On one of the VPS boxes with WHM - cpanel I have one multi-store setup with one physical e-commerce script (CS-Cart in my case) with one store on domain x and the other on domain y. The e-commerce script by default is installed on domain x and the SSL in place is being recognized as for domain x, the second store however the padlock in the browser is recognized for belonging to domain y but not by - an ssl checker like https://www.sslshopper.com/ssl-checker.html

    So based on both the recommendation of cPanelMichael and you vanessa I should just re-install the original single domain ssl certificate that previously was used for one store with an unique IP on another cpanel account in this add-on domain in the main account on which the multi store setup is based.

    Is that assumption correct ?

    Regards

    Anthony
     
Loading...

Share This Page