Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Issue with WHMCS Module - XML-API removal

Discussion in 'General Discussion' started by DennisMidjord, Jul 30, 2018.

  1. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    141
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    Does v74 not work with the module for WHMCS 5.3? We're not able to suspend accounts. This is the error we see in the module log:
    Code:
    Array
    (
        [HTML] => Array
            (
                [HEAD] => Array
                    (
                        [META] => Array
                            (
                                [0] =>
                                [META] => Array
                                    (
                                        [0] =>
                                        [1] =>
                                    )
    
                                [TITLE] => WHM Login
                                [LINK] => Array
                                    (
                                        [0] =>
                                        [1] =>
                                        [2] =>
                                    )
    
                                [STYLE] =>
    /*
      This css is included in the base template in case the css cannot be loaded because of access restrictions
      If this css is updated, please update securitypolicy_header.html.tmpl as well
    */
    .copyright {
      background: url(- Removed -) no-repeat scroll center top transparent;
      background-size: 25px auto;
    }
     
                                [SCRIPT] =>
        window.DOM = { get: function(id) { return document.getElementById(id) } };
     
                            )
    
                    )
    
            )
    
    )
    
    
     
    #1 DennisMidjord, Jul 30, 2018
    Last edited: Jul 31, 2018
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What module is it you speak of?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    141
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    The cPanel module for WHMCS that's creating, suspending, unsuspending and terminating accounts.
    After upgrading to v74, we can no longer use any of the functions.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you asked this question over on WHMCS forums?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    141
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    I've just done that. I just figured someone might now if the API was updated and no longer supports the old module commands :)
     
  6. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    728
    Likes Received:
    248
    Trophy Points:
    93
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    WHMCS 5.3 went End Of Life October 31, 2015. Perhaps you should consider upgrading to a newer version ?

    Long Term Support - WHMCS Documentation
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    141
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    Hi @rpvw
    I'm aware, but the current website has so much custom code that doesn't work in newer versions, unfortunately. When we bought the company, the old coders had created the design from scratch with minimal of the default WHMCS code. Much of the code is supported by an API they made, and we haven't had time to take a look at it yet. Unfortunately, it's not my decision, but my boss'.
     
  8. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,230
    Likes Received:
    161
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @DennisMidjord

    Unfortunately it's more than likely there are compatibility issues between WHMCS 5.3 and the latest versions of cPanel. This is the downside of EoL software. Is there anything noted in
    Code:
    /usr/local/cpanel/logs/error_log
    when attempting to suspend/unsuspend? The WHMCS module logs don't really provide much assistance to us in terms of what's happening with cPanel when the action occurs.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. DennisMidjord

    DennisMidjord Well-Known Member

    Joined:
    Sep 27, 2016
    Messages:
    141
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Denmark
    cPanel Access Level:
    Root Administrator
    Hi @cPanelLauren!

    The XML API has been removed which is why it won't work, I assume. I've finally convinced my boss to upgrade WHMCS, which will be done as soon as we have the new design. Thanks!
     
    cPanelLauren likes this.
  10. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,230
    Likes Received:
    161
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @DennisMidjord

    That would more than likely be the issue. We did deprecate XML-API. I'm glad to hear that you've convinced your boss to update WHMCS - it really is best to be running current versions of software such as this, if for no other reasons than security.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #10 cPanelLauren, Aug 6, 2018
    Last edited: Aug 8, 2018
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice