The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues resolving a requirement for Innodb (MySQL fails to restart, innodb installed)

Discussion in 'Database Discussions' started by stardotstar, Oct 8, 2010.

  1. stardotstar

    stardotstar Well-Known Member

    Joined:
    Sep 14, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Hi all,

    I apparently have the innodb engine available on my whm server:

    Code:
    root@jupiter [/etc/init.d]# mysqladmin variables | grep have_innodb
    | have_innodb                             | YES    
    I have an application that is reporting no assignment of the innodb memory it wants (half the physical ram - I have 22G)

    The ActiveCampaign email marketing solution has started complaining (I don't think it always did this!)

    I find no skip_innodb in my my.cnf

    Code:
    root@jupiter [/etc/init.d]# cat /etc/my.cnf
    [mysqld]
    local-infile=0
    tmpdir = /dev/shm
    #safe-show-database
    max_connections = 650
    max_user_connections=50
    key_buffer_size = 512M
    myisam_sort_buffer_size = 64M
    join_buffer_size = 1M
    read_buffer_size = 1M
    sort_buffer_size = 2M
    table_cache = 4000
    thread_cache_size = 384
    wait_timeout = 40
    connect_timeout = 20
    tmp_table_size = 64M
    max_heap_table_size = 64M
    max_allowed_packet = 64M
    net_buffer_length = 16384
    max_connect_errors = 10
    thread_concurrency = 8
    concurrent_insert = 2
    #table_lock_wait_timeout only for mysql5
    table_lock_wait_timeout = 40
    read_rnd_buffer_size = 786432
    bulk_insert_buffer_size = 8M
    query_cache_limit = 7M
    query_cache_size = 64M
    query_cache_type = 1
    query_prealloc_size = 262144
    query_alloc_block_size = 65536
    transaction_alloc_block_size = 8192
    transaction_prealloc_size = 4096
    max_write_lock_count = 16
    skip-name-resolve
    skip-locking
    
    [mysqld_safe]
    open_files_limit = 8192
    
    [mysqldump]
    quick
    max_allowed_packet = 16M
    
    [myisamchk]
    key_buffer = 384M
    sort_buffer = 384M
    read_buffer = 256M
    write_buffer = 256M
    and therefore I tried what was suggested on the ActiveCampaign server optimisation pages after finding that my cpanel/whm server should support use of the innodb engine just fine...

    but when I add:
    Code:
    innodb_flush_log_at_trx_commit=0
    innodb_bugger_pool_size=8G
    to the my.cnf MySQL won't restart complaining of a lock file:

    Code:
    root@jupiter [/etc/init.d]# ./mysql status
    MySQL running (2973)                                       [  OK  ]
    root@jupiter [/etc/init.d]# ./mysql
    Usage: ./mysql  {start|stop|restart|reload|force-reload|status}  [ MySQL server options ]
    root@jupiter [/etc/init.d]# ./mysql reload
    Reloading service MySQL                                    [  OK  ]
    root@jupiter [/etc/init.d]# ./mysql restart
    Shutting down MySQL...                                     [  OK  ]
    Starting MySQL.Manager of pid-file quit without updating fi[FAILED]
    root@jupiter [/etc/init.d]# ./mysql status
    MySQL is not running, but lock exists                      [FAILED]
    root@jupiter [/etc/init.d]# ./mysql start
    

    The error seems to be:
    Code:
    Starting MySQL.Manager of pid-file quit without updating fi
    When I hash out the lines for innodb it starts fine...

    Any ideas on this guys; I may have been trying an impossible thing but don't know it.

    TIA
    WIll
     
  2. InterServed

    InterServed Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    255
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Maybe because of your mistake:
    innodb_bugger_pool_size=8G

    should be : innodb_buffer_pool_size=8G
     
  3. stardotstar

    stardotstar Well-Known Member

    Joined:
    Sep 14, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Oh, how embarrassment! Thank you. :eek:
    I'll try that right away.
    Will
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please note that when you have an error on starting MySQL, the best place to find what is causing the failure would be the error log for MySQL at /var/lib/mysql/hostname.err location.

    You can always do:

    Code:
    cd /var/lib/mysql
    ls -lah *.err
    This would output then the name of the error log for MySQL. At that point, you can tail it while trying to restart MySQL in another window to see the results for the error:

    Code:
    tail -f hostname.err
     
  5. stardotstar

    stardotstar Well-Known Member

    Joined:
    Sep 14, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Thank you for that additional help. I find that setting the buffer size to 8G has allowed the MySQL Service to start normally but made Round Cube report Service Unavailable and triggered an update for Active Campaign that I was not expecting - needing the serialnumber for it took me to my webmail which was broken so I rolled back the config again.
    Thank you for your help that is most appreciated!
    WIll
     
Loading...
Similar Threads - Issues resolving requirement
  1. XxUnkn0wnxX
    Replies:
    7
    Views:
    268

Share This Page